diff mbox series

[bug#65542] gnu: intel-xed: Update to 2023.08.21.

Message ID 5365959605f2d6878cd124cd3938b84d26a05ddc.1693019039.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#65542] gnu: intel-xed: Update to 2023.08.21. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Aug. 26, 2023, 3:04 a.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/assembly.scm (intel-xed): Update to 2023.08.21.
[source]: Remove patches.
[native-inputs]: Remove tcsh.  Update mbuild to 2022.07.28.
* gnu/packages/patches/intel-xed-fix-nondeterminism.patch: Remove file
* gnu/local.mk (dist_patch_DATA): Remove it.
---
 gnu/local.mk                                  |   1 -
 gnu/packages/assembly.scm                     |  18 ++-
 .../intel-xed-fix-nondeterminism.patch        | 113 ------------------
 3 files changed, 7 insertions(+), 125 deletions(-)
 delete mode 100644 gnu/packages/patches/intel-xed-fix-nondeterminism.patch


base-commit: d17eea747277643811134f9a33b534e58160688f

Comments

宋文武 Aug. 28, 2023, 10:55 a.m. UTC | #1
Pushed, closing.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index ee4567c857..99145efbd9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1407,7 +1407,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch	\
   %D%/packages/patches/inkscape-poppler-compat.patch		\
   %D%/packages/patches/instead-use-games-path.patch		\
-  %D%/packages/patches/intel-xed-fix-nondeterminism.patch	\
   %D%/packages/patches/intltool-perl-compatibility.patch	\
   %D%/packages/patches/iputils-libcap-compat.patch		\
   %D%/packages/patches/irrlicht-use-system-libs.patch		\
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 4494c475ce..81e38c3f41 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -470,20 +470,18 @@  (define-public armips
 (define-public intel-xed
   (package
     (name "intel-xed")
-    (version "12.0.1")
+    (version "2023.08.21")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/intelxed/xed")
-             (commit version)))
-       (sha256 (base32 "07zfff8zf29c2n0wal87hiqfq3cwcjn80zz78mz0nyjfj09nd39f"))
-       (file-name (git-file-name name version))
-       (patches (search-patches "intel-xed-fix-nondeterminism.patch"))))
+             (commit (string-append "v" version))))
+       (sha256 (base32 "1zv99m5h3n3w6jcpplznq030s5mlwg5llz3vgfwpfl5l8laz1032"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (native-inputs
      `(("python" ,python-wrapper)
-       ("tcsh" ,tcsh)
        ;; As of the time of writing this comment, mbuild does not exist in the
        ;; Python Package Index and seems to only be used by intel-xed, so we
        ;; opt to include it here instead of packaging separately.  Note also
@@ -491,15 +489,15 @@  (define-public intel-xed
        ;; reference the "version" variable from setup.py instead.
        ("mbuild"
         ,(let ((name "mbuild")
-               (version "0.2496"))
+               (version "2022.07.28"))
            (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/intelxed/mbuild")
-                   (commit "3de3f0d753c11dbe634bec611d4cc13f74768e4f")))
+                   (commit (string-append "v" version))))
              (sha256
               (base32
-               "0z8hdhpmk8y5c9429p2yns9daswnffbprni9czkq3vij8f58lkg4"))
+               "0rc9xp202yqw42bwgylwxvfvjr1crdl50qvv8vzfczyvlf4wflcx"))
              (file-name (git-file-name name version)))))))
     (outputs '("out" "lib"))
     (arguments
@@ -585,5 +583,3 @@  (define-public neon2sse
 SSE4.2) intrinsic functions as defined in corresponding x86 compilers headers
 files.")
       (license license:bsd-2))))
-
-
diff --git a/gnu/packages/patches/intel-xed-fix-nondeterminism.patch b/gnu/packages/patches/intel-xed-fix-nondeterminism.patch
deleted file mode 100644
index c81bd0edde..0000000000
--- a/gnu/packages/patches/intel-xed-fix-nondeterminism.patch
+++ /dev/null
@@ -1,113 +0,0 @@ 
-This patch removes sources of build non-determinism in the upstream sources.
-
-In particular, many of the compiled sources are generated with Python code,
-which in turn uses dictionaries to index the output C functions.  However,
-iterators over Python dictionaries have no guaranteed order, thus resulting in
-the C functions being output in a random order between builds.
-
-The patch below fixes this by forcing an order during output in several key
-places.  Note, however, that future updates may uncover new such places that
-just happen to be non-problematic at the time of this patch.  If you are
-reading this due to finding such issues, feel free to contact me at
-elaexuotee@wilsonb.com for help.
-
-diff --git a/pysrc/ild_codegen.py b/pysrc/ild_codegen.py
-index 628ec45..a9bff79 100755
---- a/pysrc/ild_codegen.py
-+++ b/pysrc/ild_codegen.py
-@@ -188,14 +188,14 @@ def gen_l2_func_list(agi, target_nt_dict, arg_nt_dict,
-                      ild_t_member):
-     """generate L2 functions"""
-     l2_func_list = []
--    for (nt_name,array) in target_nt_dict.items():
-+    for (nt_name,array) in sorted(target_nt_dict.items()):
-         target_opname = array.get_target_opname()
-         if array.is_const_lookup_fun():
-             fo = gen_const_l2_function(agi, nt_name,
-                                 target_opname, ild_t_member)
-             l2_func_list.append(fo)
-         else:
--            for arg_nt_seq,arg_arr in arg_nt_dict.items():
-+            for arg_nt_seq,arg_arr in sorted(arg_nt_dict.items()):
-                 fo = gen_scalable_l2_function(agi, nt_name,
-                      target_opname, ild_t_member, arg_arr, list(arg_nt_seq))
-                 l2_func_list.append(fo)
-diff --git a/pysrc/ild_disp.py b/pysrc/ild_disp.py
-index 942c036..cf80e29 100755
---- a/pysrc/ild_disp.py
-+++ b/pysrc/ild_disp.py
-@@ -350,7 +350,8 @@ def work(agi, united_lookup,  disp_nts, brdisp_nts, ild_gendir,
-     disp_dict = _gen_l3_array_dict(agi, disp_nts, _disp_token)
- 
-     
--    nt_arr_list = list(brdisp_dict.values()) + list(disp_dict.values())
-+    nt_arr_list = ([v for (k,v) in sorted(brdisp_dict.items())] +
-+                   [v for (k,v) in sorted(disp_dict.items())])
-     #create function that calls all initialization functions
-     init_f = ild_nt.gen_init_function(nt_arr_list, 'xed_ild_disp_l3_init')
-     
-@@ -367,7 +368,7 @@ def work(agi, united_lookup,  disp_nts, brdisp_nts, ild_gendir,
-     l2_functions = []
-     eosz_op = ild_eosz.get_target_opname()
-     easz_op = ild_easz.get_target_opname()
--    for nt_name,array in list(disp_dict.items()) + list(brdisp_dict.items()):
-+    for nt_name,array in sorted(disp_dict.items()) + sorted(brdisp_dict.items()):
-         #Some DISP NTs depend on EOSZ, others on EASZ, we need to know
-         #that when we generate L2 functions
-         if eosz_op in array.get_arg_names():
-diff --git a/pysrc/ild_easz.py b/pysrc/ild_easz.py
-index 02cd691..c53b9f2 100755
---- a/pysrc/ild_easz.py
-+++ b/pysrc/ild_easz.py
-@@ -165,9 +165,10 @@ def work(agi, united_lookup, easz_nts, ild_gendir, debug):
-             return
-         nt_seq_arrays[tuple(nt_seq)] = array
-     #init function calls all single init functions for the created tables
--    init_f = ild_nt.gen_init_function(list(nt_seq_arrays.values()),
-+    nt_seq_values = [v for (k,v) in sorted(nt_seq_arrays.items())]
-+    init_f = ild_nt.gen_init_function(nt_seq_values,
-                                        'xed_ild_easz_init')
--    ild_nt.dump_lu_arrays(agi, list(nt_seq_arrays.values()), _easz_c_fn, 
-+    ild_nt.dump_lu_arrays(agi, nt_seq_values, _easz_c_fn, 
-                           mbuild.join('include-private', _easz_header_fn),
-                           init_f)
-     getter_fos = []
-diff --git a/pysrc/ild_eosz.py b/pysrc/ild_eosz.py
-index 6643bc3..89d2d89 100755
---- a/pysrc/ild_eosz.py
-+++ b/pysrc/ild_eosz.py
-@@ -200,10 +200,11 @@ def work(agi, united_lookup, eosz_nts, ild_gendir, debug):
-             return None
-         nt_seq_arrays[tuple(nt_seq)] = array
-     #init function calls all single init functions for the created tables
--    init_f = ild_nt.gen_init_function(list(nt_seq_arrays.values()), 
-+    nt_seq_values = [v for (k,v) in sorted(nt_seq_arrays.items())]
-+    init_f = ild_nt.gen_init_function(nt_seq_values, 
-                                       'xed_ild_eosz_init')
-     #dump init and lookup functions for EOSZ sequences
--    ild_nt.dump_lu_arrays(agi, list(nt_seq_arrays.values()), _eosz_c_fn,
-+    ild_nt.dump_lu_arrays(agi, nt_seq_values, _eosz_c_fn,
-                           mbuild.join('include-private', _eosz_header_fn),
-                           init_f)
-     #generate EOSZ getter functions - they get xed_decoded_inst_t*
-diff --git a/pysrc/ild_imm.py b/pysrc/ild_imm.py
-index 51c413c..0530bae 100755
---- a/pysrc/ild_imm.py
-+++ b/pysrc/ild_imm.py
-@@ -322,12 +322,14 @@ def work(agi, united_lookup, imm_nts, ild_gendir, eosz_dict,
-                                      level='l3')
-         nt_dict[nt_name] = array
- 
-+    nt_dict_values = [v for (k,v) in sorted(nt_dict.items())]
-+
-     #create function that calls all initialization functions for L3
--    init_f = ild_nt.gen_init_function(list(nt_dict.values()),
-+    init_f = ild_nt.gen_init_function(nt_dict_values,
-                                       'xed_ild_imm_l3_init')
-     
-     #dump L3 functions
--    ild_nt.dump_lu_arrays(agi, list(nt_dict.values()), _l3_c_fn,
-+    ild_nt.dump_lu_arrays(agi, nt_dict_values, _l3_c_fn,
-                           mbuild.join('include-private',_l3_header_fn),
-                           init_f)
-