diff mbox series

[bug#67812] gnu: skalibs: Correct symlink permissions on the hurd.

Message ID 52c1fda3674c848f5569fa35427921938aa140a2.1702472497.git.mail@cbaines.net
State New
Headers show
Series [bug#67812] gnu: skalibs: Correct symlink permissions on the hurd. | expand

Commit Message

Christopher Baines Dec. 13, 2023, 1:01 p.m. UTC
* gnu/packages/skarnet.scm (skalibs)[arguments]: Patch tools/install.sh umask.

Change-Id: Ia431a06d6150b33562dcf0f57eb3ba0fd84ba864
---
 gnu/packages/skarnet.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)


base-commit: 5f812344d293e5faaca44eeaab3b889fa6cb7e33

Comments

Christopher Baines Dec. 22, 2023, 5:37 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> * gnu/packages/skarnet.scm (skalibs)[arguments]: Patch tools/install.sh umask.
>
> Change-Id: Ia431a06d6150b33562dcf0f57eb3ba0fd84ba864
> ---
>  gnu/packages/skarnet.scm | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
> index 6781e2eb58..eef4e6b6f9 100644
> --- a/gnu/packages/skarnet.scm
> +++ b/gnu/packages/skarnet.scm
> @@ -42,8 +42,12 @@ (define-public skalibs
>      (arguments
>       '(#:tests? #f                      ; no tests exist
>         #:phases (modify-phases %standard-phases
> -                  (add-after 'unpack 'reproducible
> +                  (add-after 'unpack 'patch
>                      (lambda _
> +                      ;; This umask makes the symlinks in lib readable on
> +                      ;; i586-gnu
> +                      (substitute* "tools/install.sh"
> +                        (("umask 077") "umask 033"))
>                        ;; Sort source files deterministically so that the *.a
>                        ;; and *.so files are reproducible.
>                        (substitute* "Makefile"
>
> base-commit: 5f812344d293e5faaca44eeaab3b889fa6cb7e33

Pushed to master as f18f59fa4b249bbde6290ac5b91f6cd524b60848.

I also restored i586-gnu in the supported-systems.
diff mbox series

Patch

diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index 6781e2eb58..eef4e6b6f9 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -42,8 +42,12 @@  (define-public skalibs
     (arguments
      '(#:tests? #f                      ; no tests exist
        #:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'reproducible
+                  (add-after 'unpack 'patch
                     (lambda _
+                      ;; This umask makes the symlinks in lib readable on
+                      ;; i586-gnu
+                      (substitute* "tools/install.sh"
+                        (("umask 077") "umask 033"))
                       ;; Sort source files deterministically so that the *.a
                       ;; and *.so files are reproducible.
                       (substitute* "Makefile"