diff mbox series

[bug#54457,8/9] gnu: Add libnetfilter-log

Message ID 524e47d3-af2a-d12c-42fd-f7d8f30a7a0d@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

fesoj000 March 21, 2022, 9:20 p.m. UTC
* gnu/packages/linux.scm (libnetfilter-log): New variable.
---
  gnu/packages/linux.scm | 30 ++++++++++++++++++++++++++++++
  1 file changed, 30 insertions(+)

Comments

fesoj000 March 21, 2022, 9:31 p.m. UTC | #1
> +     (uri (string-append "https://netfilter.org/projects/" name "/files/" name
> +                         "-" version ".tar.bz2"))
wrong patch ... resending shortly.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 49abac08d5..3124e57ef0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7458,6 +7458,36 @@  (define-public nfacct
     (home-page "https://netfilter.org/projects/nfacct/index.html")
     (license license:gpl2+)))
  
+(define-public libnetfilter-log
+  (package
+   (name "libnetfilter-log")
+   (version "1.0.2")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "https://netfilter.org/projects/" name "/files/" name
+                         "-" version ".tar.bz2"))
+     (sha256
+      (base32
+       "1spy9xs41v76kid5ana8n126f3mvgq6fjibbfbj4kn0larbhix73"))))
+   (build-system gnu-build-system)
+   (supported-systems (filter target-linux? %supported-systems))
+   (native-inputs (list pkg-config))
+   (inputs (list libnfnetlink libmnl))
+   (synopsis "Userspace library providing interface to packets logged by
+netfilter.")
+   (description "libnetfilter_log is a userspace library providing interface to
+packets that have been logged by the kernel packet filter. It is is part of a
+system that deprecates the old syslog/dmesg based packet logging. This library
+has been previously known as libnfnetlink_log.
+@enumerate
+@item
+receiving to-be-logged packets from the kernel nfnetlink_log subsystem
+@end enumerate
+")
+   (home-page "https://netfilter.org/projects/libnetfilter_log/index.html")
+   (license license:gpl2+)))
+
  (define-public proot
    (package
      (name "proot")