diff mbox series

[bug#60869] gnu: Add emacs-org-board.

Message ID 51e3225c3ac9ab8e9560768ccc047c73e6403a6d.1673907375.git.csantosb@inventati.org
State New
Headers show
Series [bug#60869] gnu: Add emacs-org-board. | expand

Commit Message

Cayetano Santos Jan. 16, 2023, 10:16 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-board): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 0cf98fbc4e1facbdd733eecf8442788179722c6e

Comments

Nicolas Goaziou Jan. 20, 2023, 11:38 p.m. UTC | #1
Hello,

Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-org-board): New variable.

Applied with a few changes, noted below. Thank you.

> +(define-public emacs-org-board
> +  (let ((commit "1393bd46d11a81328ed4fb8471831415a3efe224")
> +        (revision "1"))
> +    (package
> +      (name "emacs-org-board")
> +      (version (git-version "20200619" revision commit))

Base version is 1138, not 20200619.

> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "https://github.com/charlesroelli/org-board")
> +                      (commit commit)))
> +                (sha256
> +                 (base32
> +                  "1kryrg988c3sbxyp1sdgc6xdv2iz6kiflpzn2rw4z3l4grzab53b"))))
> +      (build-system emacs-build-system)
> +      (propagated-inputs (list emacs-org emacs-ztree wget))

I moved wget to regular inputs and added a phase so the package could
find the wget executable.

> +      (home-page "https://github.com/charlesroelli/org-board")
> +      (synopsis "Bookmarking and web archival system for Org mode")
> +      (description
> +       "Org-board uses `org-attach and `wget to provide a bookmarking and web
> +archival system directly from an Org file..")

I reworded the description.

> +      (license license:gpl3+))))

License is GPL2+.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dfbd51ac0a..d202108f27 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -251,6 +251,7 @@  (define-module (gnu packages emacs-xyz)
   #:use-module (gnu packages erlang)
   #:use-module (gnu packages statistics)
   #:use-module (gnu packages libcanberra)
+  #:use-module (gnu packages wget)
   #:use-module (guix utils)
   #:use-module (srfi srfi-1)
   #:use-module (ice-9 match))
@@ -24937,6 +24938,29 @@  (define-public emacs-cpreproc-openvdb
 incompatible versions of it.")
    (license license:gpl3+)))
 
+(define-public emacs-org-board
+  (let ((commit "1393bd46d11a81328ed4fb8471831415a3efe224")
+        (revision "1"))
+    (package
+      (name "emacs-org-board")
+      (version (git-version "20200619" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/charlesroelli/org-board")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "1kryrg988c3sbxyp1sdgc6xdv2iz6kiflpzn2rw4z3l4grzab53b"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-org emacs-ztree wget))
+      (home-page "https://github.com/charlesroelli/org-board")
+      (synopsis "Bookmarking and web archival system for Org mode")
+      (description
+       "Org-board uses `org-attach and `wget to provide a bookmarking and web
+archival system directly from an Org file..")
+      (license license:gpl3+))))
+
 (define-public emacs-org-brain
   (package
     (name "emacs-org-brain")