diff mbox series

[bug#67297,2/2] gnu: mkvtoolnix: Update to 80.0.

Message ID 51b0dbf7393ec05ce8a566266fc998562a128b96.1700488105.git.antoine.cote@posteo.net
State New
Headers show
Series [bug#67296,1/2] gnu: libmatroska: Update to 1.7.1. | expand

Commit Message

Antoine Côté Nov. 20, 2023, 2:51 p.m. UTC
* gnu/packages/video.scm (mkvtoolnix): Update to 80.0.

Change-Id: If01ce578c9f9ac50e1c99e96c110687e8872177c
---
 gnu/packages/video.scm | 14 ++++++++------
 1 file changed, 8 insertions(+), 6 deletions(-)

Comments

Sharlatan Hellseher Nov. 20, 2023, 5:55 p.m. UTC | #1
Hi,

Thank you for the patch.

It looks reasonable for me, one missing part is to add commit annotation
about changes in inputs and native inputs.

Thanks,
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 41bcb8c385..e057e53b24 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -971,14 +971,14 @@  (define-public libx264
 (define-public mkvtoolnix
   (package
     (name "mkvtoolnix")
-    (version "52.0.0")
+    (version "80.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://mkvtoolnix.download/sources/"
                            "mkvtoolnix-" version ".tar.xz"))
        (sha256
-        (base32 "15y7ahlifsclnkl70wn5w34dil8nwcwcjnw3k2ydqc6dz4vb0j5s"))
+        (base32 "1x9k9pmw7mzm2amvm251a45dlj9p9iqfank5p4w2fizxkapws25v"))
        (modules '((guix build utils)))
        (snippet '(begin
                    ;; Delete bundled libraries.
@@ -994,6 +994,7 @@  (define-public mkvtoolnix
     (outputs '("out" "gui")) ; "mkvtoolnix-gui" brings the closure size from ~300 MB to 1.5+ GB.
     (inputs
      (list boost
+           gmp
            bzip2
            cmark
            libebml
@@ -1007,8 +1008,9 @@  (define-public mkvtoolnix
            lzo
            pcre2
            pugixml
-           qtbase-5
-           qtmultimedia-5
+           qtbase
+           qtmultimedia
+           qtsvg
            utfcpp
            zlib))
     (native-inputs
@@ -1020,8 +1022,8 @@  (define-public mkvtoolnix
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("po4a" ,po4a)
-       ("qttools-5" ,qttools-5)
-       ("ruby" ,ruby-2.7)))
+       ("qttools" ,qttools)
+       ("ruby" ,ruby-3.2)))
     (arguments
      `(#:configure-flags
        (list (string-append "--with-boost="