diff mbox series

[bug#58501,v2,3/3] gnu: Add low-memory-monitor

Message ID 51a9c9f7e617c42e11eb0b63518456763130fdf6.1667508108.git.florhizome@posteo.net
State New
Headers show
Series [bug#58501,v2,1/3] gnu: Add iio-sensor-proxy | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

florhizome Nov. 3, 2022, 8:59 p.m. UTC
From: florhizome <florhizome@posteo.net>

* gnu/packages/freedesktop.scm (Add low-memory-monitor): New variable.
---
 gnu/packages/freedesktop.scm | 43 ++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 5c2cc16345..736c951c68 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1735,6 +1735,49 @@  (define-public libqmi
      ;; The qmicli tool is released under the GPLv2+ license.
      (list license:lgpl2.0+ license:gpl2+))))
 
+(define-public low-memory-monitor
+ (package
+    (name "low-memory-monitor")
+    (version "2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.freedesktop.org/hadess/low-memory-monitor")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0431wzn9q2hnx0mwai8w3bcmbln8g76r7wyyhjbkamnl2sccl8jn"))))
+    (build-system meson-build-system)
+    (arguments
+     (list #:configure-flags #~(list "-Dsystemdsystemunitdir=false")
+           #:glib-or-gtk? #t))
+    (native-inputs
+     (list (list glib "bin") gobject-introspection gtk-doc libxml2
+           pkg-config))
+   (inputs
+    (list glib libgudev eudev))
+   (home-page "https://gitlab.freedesktop.org/hadess/low-memory-monitor")
+
+   (synopsis "Daemon to send information about memory pressure to userspace")
+   (description
+    "Low Memory Monitor is an early boot daemon that will monitor memory
+pressure information coming from the kernel, and, when memory pressure means
+that memory isn't as readily available and would cause interactivity problems,
+ would:
+
+@itemize
+@item send D-Bus signals to user-space applications when memory is running low,
+
+@item if configured to do so and memory availability worsens, activate the
+ kernel's OOM killer.
+@end itemize
+
+It is designed for use on traditional Linux systems, with interactive user
+interfaces and D-Bus communication.")
+   (license license:gpl3)))
+
 (define-public modem-manager
   (package
     (name "modem-manager")