[bug#33514] shepherd: fix bootstrap/build from git

Message ID 51974da7-e8d6-7b3d-ba6b-e0c4bc4210c1@gmail.com
State Accepted
Headers show
Series [bug#33514] shepherd: fix bootstrap/build from git | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Florian Dold Nov. 26, 2018, 2:43 p.m. UTC
Hi all,

the Shepherd currently does not build from a clean git repository (on
GuixSD in a shepherd environment), as "autoreconf -ifv" does not create
missing files related to gettext unless the version is specified.

This tiny patch fixes the gettext version and allows bootstrapping to
work from a clean git checkout.

By the way, shouldn't there also be a "./bootstrap" shell script, as is
customary in a lot of projects including Guix?

Cheers,
Florian

Comments

Ludovic Courtès Nov. 26, 2018, 4:31 p.m. UTC | #1
Hi Florian,

Florian Dold <florian.dold@gmail.com> skribis:

> the Shepherd currently does not build from a clean git repository (on
> GuixSD in a shepherd environment), as "autoreconf -ifv" does not create
> missing files related to gettext unless the version is specified.
>
> This tiny patch fixes the gettext version and allows bootstrapping to
> work from a clean git checkout.

Good catch, applied!

> By the way, shouldn't there also be a "./bootstrap" shell script, as is
> customary in a lot of projects including Guix?

FWIW I prefer to just run “autoreconf -vfi”, which is what ‘./bootstrap’
does in Guix.  ‘./bootstrap’ scripts tend to have different semantics
between projects (some run ‘./configure’, some don’t, etc.) so I like to
keep it simple.

Thoughts?

Thanks,
Ludo’.

Patch

From a835aa7295d20ddd207ec44401a044be631fe3a4 Mon Sep 17 00:00:00 2001
From: Florian Dold <flo@dold.me>
Date: Mon, 26 Nov 2018 12:59:37 +0100
Subject: [PATCH] build: set gettext version to make bootstrap work

* configure.ac: add AM_GNU_GETTEXT_VERSION
---
 configure.ac | 1 +
 1 file changed, 1 insertion(+)

diff --git a/configure.ac b/configure.ac
index 79483b4..3877913 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,6 +15,7 @@  dnl Enable silent rules by default.
 AM_SILENT_RULES([yes])
 
 AM_GNU_GETTEXT([external])
+AM_GNU_GETTEXT_VERSION([0.19])
 
 AC_CANONICAL_HOST
 AC_PROG_MKDIR_P
-- 
2.19.1