diff mbox series

[bug#73665] gnu: Add emacs-varuga.

Message ID 5195826fe31375bc454790e1727b7a3f131d8199.1728237711.git.arunisaac@systemreboot.net
State New
Headers show
Series [bug#73665] gnu: Add emacs-varuga. | expand

Commit Message

Arun Isaac Oct. 6, 2024, 6:02 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-varuga): New variable.

Change-Id: I6900893ff65011fd8aa935a6b7281e83842b2b66
---
 gnu/packages/emacs-xyz.scm | 31 ++++++++++++++++++++++++++++++-
 1 file changed, 30 insertions(+), 1 deletion(-)


base-commit: 970631c36f0369318f184ff3251672d4fc5d24c1

Comments

Nicolas Goaziou Oct. 15, 2024, 7:20 a.m. UTC | #1
Hello,

Arun Isaac <arunisaac@systemreboot.net> writes:

> * gnu/packages/emacs-xyz.scm (emacs-varuga): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 09ac57a464..869897573b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16,7 +16,7 @@ 
 ;;; Copyright © 2016, 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2016-2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2016-2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016-2022, 2024 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2017, 2018, 2019, 2020, 2022 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017, 2018, 2019, 2020, 2021, 2022 Clément Lassieur <clement@lassieur.org>
@@ -4882,6 +4882,35 @@  (define-public emacs-calfw
 Emacs buffer.")
     (license license:gpl3+)))
 
+(define-public emacs-varuga
+  (package
+    (name "emacs-varuga")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.systemreboot.net/varuga/")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "01hlnhqhys8qzfwhza1ypc436zg5lhlkx5yy71bhmrbmyfzfh0fr"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:tests? #t))
+    (home-page "https://git.systemreboot.net/varuga/about/")
+    (synopsis "Send ical calendar invites by email")
+    (description "@code{emacs-varuga} allows you to format and send ical
+calendar invites using your Emacs mail client.  These invites are similar to
+those produced by Google Calendar, Outlook Calendar, etc. and are compatible
+with them.
+
+varuga populates a message mode buffer with an ical MIME part (using MML, the
+MIME Meta Language).  It also adds a plain text part listing the time of the
+event in various configured timezones.")
+    (license license:gpl3+)))
+
 (define-public emacs-caml
   (package
     (name "emacs-caml")