diff mbox series

[bug#50673] Add python-matplotlib-inline

Message ID 515a5ea3e8f091955c4745e0d1950540ada92409.camel@courrier.dev
State Accepted
Headers show
Series [bug#50673] Add python-matplotlib-inline | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pradana Adrinusa AUMARS Sept. 19, 2021, 1:09 p.m. UTC
From fe210d397eef4f44cc269d7bbadaaae398f1127f Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Sun, 19 Sep 2021 15:06:01 +0200
Subject: [PATCH] gnu: Add python-matplotlib-inline

* gnu/packages/python-xyz.scm (python-matplotlib-inline): New variable.
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Guillaume Le Vaillant Sept. 25, 2021, 11:12 a.m. UTC | #1
Hi,

The python-matplotlib-inline package has been added on the
core-updates-frozen branch, so it will become available on the master
branch when core-updates-frozen get merged.
Guillaume Le Vaillant Jan. 31, 2022, 2:47 p.m. UTC | #2
core-updates-frozen has been merged and python-matplotlib-inline is
available in master.
Closing.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 66857b31b0..8af1d875e9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26580,3 +26580,27 @@  files and directories and adds a datestamp in standard ISO 8601+ format
 YYYY-MM-DD at the beginning of the file or directory name.")
       (home-page "https://github.com/novoid/date2name")
       (license license:gpl3+))))
+
+(define-public python-matplotlib-inline
+  (package
+    (name "python-matplotlib-inline")
+    (version "0.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "matplotlib-inline" version))
+       (sha256
+        (base32
+         "1vilzwj3xp00mxprmmn1hlafm3p23vn56s46kx3ra4qd5signjx0"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-traitlets" ,python-traitlets)))
+    (native-inputs
+     `(("python-matplotlib" ,python-matplotlib)
+       ("python-ipython" ,python-ipython)))
+    (home-page "https://github.com/ipython/matplotlib-inline")
+    (synopsis "Inline Matplotlib backend for Jupyter")
+    (description
+     "This package is included in IPython and can be used in a
+Jupyter Notebook.")
+    (license license:bsd-3)))