diff mbox series

[bug#38906] gnu: Add gnome-user-share.

Message ID 5127df1c3c1f8a1b487846bf4b02e49d61bda17a.camel@disroot.org
State Accepted
Headers show
Series [bug#38906] gnu: Add gnome-user-share. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 3, 2020, 9:08 p.m. UTC
Hello Guix!

Please find the attached patch to add gnome-user-share.

Regards,
RG.

Comments

Julien Lepiller Jan. 7, 2020, 11:34 p.m. UTC | #1
Le Fri, 03 Jan 2020 16:08:02 -0500,
Raghav Gururajan <raghavgururajan@disroot.org> a écrit :

> Hello Guix!
> 
> Please find the attached patch to add gnome-user-share.
> 
> Regards,
> RG.

Thanks for the patch!

Again, I don't really get what nautilus and gtk+ or yelp-tools are
doing for the build. Are they used in the build? Aren't they runtime
dependencies? Does the package work as expected? The description
doesn't really make it clear: does this package provide a library or
an executable? I think you can skip "free software" in the description,
we wouldn't bind together non free software anyway :)
diff mbox series

Patch

From 5075ed38d0024eb8aedb1e6a69ac69b85e0b6bba Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 16:05:06 -0500
Subject: [PATCH] gnu: Add gnome-user-share.

* gnu/packages/gnome.scm (gnome-user-share): New variable.
---
 gnu/packages/gnome.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 54e643a7ab..b1eda248ff 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -246,6 +246,37 @@  Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license license:gpl2+)))
 
+(define-public gnome-user-share
+  (package
+   (name "gnome-user-share")
+   (version "3.33.1")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version) "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "0lf790pyamdyj7180ils8vizjl8brxcg7jsm1iavfp9ay4wa8mz7"))))
+   (build-system meson-build-system)
+   (native-inputs
+    `(("gettext" ,gettext-minimal)
+      ("glib:bin" ,glib "bin")
+      ("gtk+:bin" ,gtk+ "bin")
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("gnome-bluetooth" ,gnome-bluetooth)
+      ("libcanberra" ,libcanberra)
+      ("libnotify" ,libnotify)
+      ("nautilus" ,nautilus)
+      ("yelp-tools" ,yelp-tools)))
+   (synopsis "File sharing for GNOME desktop")
+   (description "GNOME User Share is a small package that binds together
+various free software projects to bring easy to use user-level file
+sharing to the masses.")
+   (home-page "https://gitlab.gnome.org/GNOME/gnome-user-share")
+   (license license:gpl2)))
+
 (define-public gnome-initial-setup
   (package
    (name "gnome-initial-setup")
-- 
2.24.1