diff mbox series

[bug#54644,v2,1/6] gnu: rust-nom-locate-4: Add 4.0.0

Message ID 510db1c9dd45cfc1f1ef7b025fd81f8d4723ca94.1648850075.git.e.lepikhin@corp.mail.ru
State Accepted
Headers show
Series [bug#54644,v2,1/6] gnu: rust-nom-locate-4: Add 4.0.0 | expand

Commit Message

Evgenii Lepikhin April 1, 2022, 9:54 p.m. UTC
* gnu/packages/crates-io.scm (rust-nom-locate-4): Add 4.0.0
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Evgenii Lepikhin May 16, 2022, 1:49 p.m. UTC | #1
Hello Guix,

On 2022-04-02 00:54, Evgenii Lepikhin via Guix-patches via wrote:

> * gnu/packages/crates-io.scm (rust-nom-locate-4): Add 4.0.0

Could anybody review or merge this updated patchset, please?


--
Efraim Flashner May 30, 2022, 8:18 a.m. UTC | #2
On Mon, May 16, 2022 at 04:49:30PM +0300, Evgenii Lepikhin via Guix-patches via wrote:
> Hello Guix,
> 
> On 2022-04-02 00:54, Evgenii Lepikhin via Guix-patches via wrote:
> 
> > * gnu/packages/crates-io.scm (rust-nom-locate-4): Add 4.0.0
> 
> Could anybody review or merge this updated patchset, please?

I made a couple of changes. I split the rust-nom-7 patch into two, one
to add rust-minimal-lexical-0.2 and the second to update rust-nom-7. I
also cleaned up the synopsis and descriptions to make `guix lint` happy
and adjusted the commit messages.

Patches pushed! Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 90c95b6368..82fd24b310 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37465,6 +37465,31 @@  (define-public rust-nom-derive-0.7
     (description "This package derives custom nom parsers from structs.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-nom-locate-4
+  (package
+    (name "rust-nom-locate")
+    (version "4.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "nom_locate" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0186n5qbpiyhpas3nk8y4ynnbdghl4nx958bkq4a6a9hr8v48y9p"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-bytecount" ,rust-bytecount-0.6)
+        ("rust-nom" ,rust-nom-7)
+        ("rust-memchr" ,rust-memchr-2)
+        ("rust-stable-deref-trait" ,rust-stable-deref-trait-1))))
+    (home-page "https://github.com/fflorent/nom_locate")
+    (synopsis "A special input type for nom to locate tokens")
+    (description
+     "The crate provide the LocatedSpan struct that encapsulates the data.")
+    (license (list license:expat))))
+
 (define-public rust-noop-proc-macro-0.3
   (package
     (name "rust-noop-proc-macro")