diff mbox series

[bug#65482,3/3] gnu: chez-scheme-for-racket-bootstrap-bootfiles: Remove workaround.

Message ID 510912032455b5c56984242cf06997c0eff688c7.1692834182.git.philip@philipmcgrath.com
State New
Headers show
Series gnu: racket: Update to 8.10. | expand

Commit Message

Philip McGrath Aug. 24, 2023, 12:08 a.m. UTC
Architecture autodetection in rktboot was fixed upstream, and the fix is
included in racket-backport-8.10-rktboot.patch for Guix. This commit
goes beyond reverting b4fbeae3d90a5d0f8146441772436df2eb471491: the
upstream fix also supports 'pbarch' machine types, so we never need to
supply a '--machine' argument to rktboot.

* gnu/packages/chez.scm (chez-scheme-for-racket-bootstrap-bootfiles)
[arguments]: Change 'build' phase to never use '--machine' for rktboot.
---
 gnu/packages/chez.scm | 8 +-------
 1 file changed, 1 insertion(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index e5694ec1cf..3f53beac1a 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -691,13 +691,7 @@  (define-public chez-scheme-for-racket-bootstrap-bootfiles
                       #~(invoke
                          (search-input-file (or native-inputs inputs)
                                             "/opt/racket-vm/bin/racket")
-                         "../rktboot/main.rkt"
-                         ;; Temporary handling of builds on non-x86 architectures,
-                         ;; see https://github.com/racket/racket/issues/3948
-                         ;; Autodetect in rktboot only addresses x86 archs, so far.
-                         #$@(let ((m (or (racket-cs-native-supported-system?)
-                                         (nix-system->pbarch-machine-type))))
-                              #~("--machine" #$m))))))))))))
+                         "../rktboot/main.rkt"))))))))))
     (supported-systems
      (package-supported-systems chez-scheme-for-racket))
     (home-page "https://github.com/racket/ChezScheme")