[bug#77532] gnu: emacs-emacsql: Update to 4.3.0.

Message ID 50eeffad29082215e9b0190212744f3a86f87be3.1743772895.git.csantosb@inventati.org
State New
Headers
Series [bug#77532] gnu: emacs-emacsql: Update to 4.3.0. |

Commit Message

Cayetano Santos April 4, 2025, 1:21 p.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-emacsql): Update to 4.3.0.

Change-Id: Ib1cce5b0ca4709f774819a2602c2e6b96604e8ba
---

- updated
- fix license
- fix tests
- fix executable-paths
- fix inputs

Checked by building all dependent packages.

 gnu/packages/emacs-xyz.scm | 33 +++++++++++++++------------------
 1 file changed, 15 insertions(+), 18 deletions(-)


base-commit: f664a9377deed2c9e644b53a0b497153c7e7a41f
--
2.49.0
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0c49bb5d4d..0796aa1970 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25450,7 +25450,7 @@  (define-public emacs-finalize
 (define-public emacs-emacsql
   (package
     (name "emacs-emacsql")
-    (version "4.2.0")
+    (version "4.3.0")
     (source
      (origin
        (method git-fetch)
@@ -25459,34 +25459,31 @@  (define-public emacs-emacsql
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "08zc3x6cgbn2x67xajz8rnika3bhd86yb6h77q8wg1dxyh1ib2m9"))))
+        (base32 "0bjw4qbm254r51kgl0bg4scblk998p0y3m140k5lmrdb7k4pnxq2"))))
     (build-system emacs-build-system)
     (arguments
      (list
-      #:tests? #true
-      #:test-command #~(list "emacs" "-Q" "--batch"
-                             "-L" "tests"
-                             "-L" "."
-                             "-l" "tests/emacsql-compiler-tests.el"
-                             "-l" "tests/emacsql-external-tests.el"
-                             "-f" "ert-run-tests-batch-and-exit")
+      #:tests? #t
+      #:test-command #~(list "make" "test")
       #:phases
       #~(modify-phases %standard-phases
-          (add-before 'install 'patch-elisp-shell-shebangs
-            (lambda _
-              (substitute* (find-files "." "\\.el")
-                (("/bin/sh") (which "sh"))))))))
-    (inputs
-     (list emacs-minimal `(,mariadb "dev") `(,mariadb "lib") postgresql))
-    (propagated-inputs
-     (list emacs-finalize emacs-pg emacs-sqlite3-api))
+          (add-after 'unpack 'fix-executable-paths
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((mdb (assoc-ref inputs "mariadb"))
+                    (psql (assoc-ref inputs "postgresql")))
+                (emacs-substitute-variables "emacsql-psql.el"
+                  ("emacsql-psql-executable" (string-append psql "/bin/psql")))
+                (emacs-substitute-variables "emacsql-mysql.el"
+                  ("emacsql-mysql-executable" (string-append mdb "/bin/mysql")))))))))
+    (inputs (list mariadb postgresql))
+    (native-inputs (list emacs-sqlite3-api))
     (home-page "https://github.com/magit/emacsql")
     (synopsis "Emacs high-level SQL database front-end")
     (description "Any readable Lisp value can be stored as a value in EmacSQL,
 including numbers, strings, symbols, lists, vectors, and closures.  EmacSQL
 has no concept of @code{TEXT} values; it's all just Lisp objects.  The Lisp
 object @code{nil} corresponds 1:1 with @code{NULL} in the database.")
-    (license license:gpl3+)))
+    (license license:unlicense)))
 
 (define-public emacs-closql
   (package