diff mbox series

[bug#63219,mesa-branch,v3,3/4] gnu: mesa: Fix hardware video decoding.

Message ID 50d525c2c364d0a64c92b4f956eab304e370e102.1683230943.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series Mesa update plus various fixes and cleanups. | expand

Commit Message

Kaelyn Takata May 4, 2023, 8:12 p.m. UTC
* gnu/packages/gl.scm (mesa): Fix hardware video decoding.
[arguments]: Add -Dvideo-codecs to the #:configure-flags
[native-search-paths]: Add VDPAU_DRIVER_PATH so libvdpau can find the drivers.
---
 gnu/packages/gl.scm | 9 +++++++++
 1 file changed, 9 insertions(+)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index f705b864f1..5248151a95 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -362,6 +362,10 @@  (define-public mesa
          ;; Enable the Vulkan overlay layer on all architectures.
          "-Dvulkan-layers=device-select,overlay"

+         ;; Enable the codecs that were built by default as part of the
+         ;; 21.3.x releases to avoid functionality regressions.
+         "-Dvideo-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc"
+
          ;; Also enable the tests.
          "-Dbuild-tests=true"

@@ -513,6 +517,11 @@  (define-public mesa
                              (string-append "\"" out "/lib/lib" layer-name ".so\"")))))))
                (for-each fix-layer-path '("VkLayer_MESA_device_select"
                                           "VkLayer_MESA_overlay"))))))))
+    (native-search-paths
+     (list (search-path-specification
+            ;; Ensure the Mesa VDPAU drivers can be found.
+            (variable "VDPAU_DRIVER_PATH")
+            (files '("lib/vdpau")))))
     (home-page "https://mesa3d.org/")
     (synopsis "OpenGL and Vulkan implementations")
     (description "Mesa is a free implementation of the OpenGL and Vulkan