diff mbox series

[bug#70181] gnu: gama: Update to 2.30

Message ID 5096f79456d222fa39a705e0c09f85bcbe26096c.1712214920.git.atai@atai.org
State New
Headers show
Series [bug#70181] gnu: gama: Update to 2.30 | expand

Commit Message

Andy Tai April 4, 2024, 7:15 a.m. UTC
* gnu/packages/gps.scm (gama): Update to 2.30
  [source]: Remove deletion of embedded expat as expat
  distributed in guix, 2.5, does not build for this version
  of gama,  which uses expat 1.2

Change-Id: I5ce4e291da1d56a660c1e3546ef8d9daf008b140
---
 gnu/packages/gps.scm | 10 +++-------
 1 file changed, 3 insertions(+), 7 deletions(-)


base-commit: 188d18fc47f0d38edfe06e3e5834fa8587bd300b

Comments

Christopher Baines April 15, 2024, 8:44 a.m. UTC | #1
Andy Tai <atai@atai.org> writes:

> * gnu/packages/gps.scm (gama): Update to 2.30
>   [source]: Remove deletion of embedded expat as expat
>   distributed in guix, 2.5, does not build for this version
>   of gama,  which uses expat 1.2
>
> Change-Id: I5ce4e291da1d56a660c1e3546ef8d9daf008b140
> ---
>  gnu/packages/gps.scm | 10 +++-------
>  1 file changed, 3 insertions(+), 7 deletions(-)

I think it's better to stick with the older version of gama if that
builds with the version of expat that we package.

Looking at the NEWS file, I'm a bit confused why this release doesn't
work, when the previous one seemed to:

  https://git.savannah.gnu.org/cgit/gama.git/tree/NEWS
Andy Tai April 15, 2024, 7:47 p.m. UTC | #2
I will check again and possibly file a bug upstream on this.

On Mon, Apr 15, 2024 at 1:45 AM Christopher Baines <mail@cbaines.net> wrote:
>
> Andy Tai <atai@atai.org> writes:
>
> > * gnu/packages/gps.scm (gama): Update to 2.30
> >   [source]: Remove deletion of embedded expat as expat
> >   distributed in guix, 2.5, does not build for this version
> >   of gama,  which uses expat 1.2
>
> I think it's better to stick with the older version of gama if that
> builds with the version of expat that we package.
>
> Looking at the NEWS file, I'm a bit confused why this release doesn't
> work, when the previous one seemed to:
>
>   https://git.savannah.gnu.org/cgit/gama.git/tree/NEWS
diff mbox series

Patch

diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 75197ad23c..565b05b211 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -141,7 +141,7 @@  (define-public gpscorrelate
 (define-public gama
   (package
     (name "gama")
-    (version "2.29")
+    (version "2.30")
     (source
       (origin
         (method url-fetch)
@@ -149,12 +149,8 @@  (define-public gama
                             version ".tar.gz"))
         (sha256
          (base32
-          "04dlh1pdaiq059ssrxa4yn24iqgjrzy2mq7s9n1pgrzlzz3a63y0"))
-        (modules '((guix build utils)))
-        (snippet
-         '(begin
-            (delete-file-recursively "lib/expat")
-            (for-each delete-file (find-files "doc/fig" "\\.pdf$"))))))
+          "0yph6q7a0dy2r2vsrkjg26q8v988pcvnaay5lk6q7k06plpr2x1m"))
+        (modules '((guix build utils)))))
     (build-system gnu-build-system)
     (arguments '(#:parallel-tests? #f)) ; race condition
     (native-inputs