diff mbox series

[bug#68386,v2] gnu: Add emacs-vhdl-mode.

Message ID 50762c4245754a472a295ae66551ff2f7d806f1b.1705507807.git.csantosb@inventati.org
State New
Headers show
Series [bug#68386,v2] gnu: Add emacs-vhdl-mode. | expand

Commit Message

Cayetano Santos Jan. 17, 2024, 4:10 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-vhdl-mode): New variable.

Signed-off-by: Cayetano Santos <csantosb@inventati.org>
---
 gnu/packages/emacs-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)


base-commit: 3dd8bf94a9d1a2eddb6eda9da7d4a3d422b9dfe9
--
2.41.0

Comments

Maxim Cournoyer Jan. 19, 2024, 3:47 a.m. UTC | #1
Hi,

Cayetano Santos <csantosb@inventati.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-vhdl-mode): New variable.
>
> Signed-off-by: Cayetano Santos <csantosb@inventati.org>

We do not 'Signed-off-by' in Guix unless we apply patches of someone
else.  It's a different convention than for the kernel Linux
development and other projects.

I've applied it with small adjustments.
Deslauriers, Douglas via Guix-patches" via Jan. 19, 2024, 7:28 a.m. UTC | #2
>jeu. 18 janv. 2024 at 22:47, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

> Hi,
>
> Cayetano Santos <csantosb@inventati.org> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-vhdl-mode): New variable.
>>
>> Signed-off-by: Cayetano Santos <csantosb@inventati.org>
>
> We do not 'Signed-off-by' in Guix unless we apply patches of someone
> else.  It's a different convention than for the kernel Linux
> development and other projects.

You mean, it is optional, or do I better remove it next time ?
Maxim Cournoyer Jan. 19, 2024, 9:58 p.m. UTC | #3
Hi,

Cayetano Santos <csantosb@inventati.org> writes:

>>jeu. 18 janv. 2024 at 22:47, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>> Hi,
>>
>> Cayetano Santos <csantosb@inventati.org> writes:
>>
>>> * gnu/packages/emacs-xyz.scm (emacs-vhdl-mode): New variable.
>>>
>>> Signed-off-by: Cayetano Santos <csantosb@inventati.org>
>>
>> We do not 'Signed-off-by' in Guix unless we apply patches of someone
>> else.  It's a different convention than for the kernel Linux
>> development and other projects.
>
> You mean, it is optional, or do I better remove it next time ?

It's better to remove it next time.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1d99fb30ff..b7c5fbdf21 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7999,6 +7999,24 @@  (define-public emacs-rspec
 snippets for yasnippet.")
       (license license:gpl3+))))
 
+(define-public emacs-vhdl-mode
+  (package
+    (name "emacs-vhdl-mode")
+    (version "3.39.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://iis-people.ee.ethz.ch/~zimmi/emacs/vhdl-mode-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "1yvh4gyig8hgf5pahajjgsgp4jpzwgmlprwzsfybqxrcfza6f3yq"))))
+    (build-system emacs-build-system)
+    (home-page "https://iis-people.ee.ethz.ch/~zimmi/emacs/vhdl-mode.html")
+    (synopsis "Major mode for VHDL programming language")
+    (description
+     "This package provides an update of @code{vhdl-mode} included in Emacs.")
+    (license license:gpl3+)))
+
 (define-public emacs-mode-line-bell
   (package
     (name "emacs-mode-line-bell")