diff mbox series

[bug#49606,wip-haskell,v2] gnu: Add ghc-8.10.

Message ID 50732186fb1a7b17d2d44d172957ba145607debf.1627682631.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#49606,wip-haskell,v2] gnu: Add ghc-8.10. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen July 30, 2021, 10:12 p.m. UTC
* gnu/packages/haskell.scm (ghc-8.10): New variable.
---
Changes since v1:

* Fix /bin/sh path in one of the tests.

Unfortunately, I haven’t been able to fix the T16521 test; I tried
setting the C_INCLUDE_PATH variable to ‘libraries/process/include’, but
it’s still not able to find ’processFlags.h’.  Not sure if there is
anything else I could try.  Would it be OK to merge this despite the
failing test?

Also, this patch should go to the ‘wip-haskell’ branch; once/if it gets
merged it would be a good idea to update the Stackage LTS release and
update all the Haskell packages.

gnu/packages/haskell.scm | 59 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)


base-commit: f2470e9a4bcd47d526e14721bbd2693fb979d306

Comments

Xinglu Chen Aug. 12, 2021, 10:18 a.m. UTC | #1
On Sat, Jul 31 2021, Xinglu Chen wrote:

> * gnu/packages/haskell.scm (ghc-8.10): New variable.
> ---
> Changes since v1:
>
> * Fix /bin/sh path in one of the tests.
>
> Unfortunately, I haven’t been able to fix the T16521 test; I tried
> setting the C_INCLUDE_PATH variable to ‘libraries/process/include’, but
> it’s still not able to find ’processFlags.h’.  Not sure if there is
> anything else I could try.  Would it be OK to merge this despite the
> failing test?
>
> Also, this patch should go to the ‘wip-haskell’ branch; once/if it gets
> merged it would be a good idea to update the Stackage LTS release and
> update all the Haskell packages.

Any comments/thoughts on this, anyone?
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 09732fc594..089ea7ceb0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
 ;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -657,6 +658,64 @@  interactive environment for the functional language Haskell.")
                                 (file-pattern ".*\\.conf\\.d$")
                                 (file-type 'directory))))))
 
+(define-public ghc-8.10
+  (package
+    (inherit ghc-8.8)
+    (name "ghc")
+    (version "8.10.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.haskell.org/ghc/dist/"
+                           version "/ghc-" version "-src.tar.xz"))
+       (sha256
+        (base32 "0vq7wch0wfvy2b5dbi308lq5225vf691n95m19c9igagdvql22gi"))))
+    (native-inputs
+     `(("ghc-bootstrap" ,ghc-8.8)
+       ("ghc-testsuite"
+        ,(origin
+           (method url-fetch)
+           (uri (string-append
+                 "https://www.haskell.org/ghc/dist/"
+                 version "/ghc-" version "-testsuite.tar.xz"))
+           (patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
+           (sha256
+            (base32
+             "0vcq774rfb6q8vsnh7p5clxp2qaz8ip6d2bm2ghbq53n8jl296d6"))))
+       ("git" ,git-minimal)                     ; invoked during tests
+       ,@(filter (match-lambda
+                   (("ghc-bootstrap" . _) #f)
+                   (("ghc-testsuite" . _) #f)
+                   (_ #t))
+                 (package-native-inputs ghc-8.8))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments ghc-8.8)
+       ((#:phases phases '%standard-phases)
+        `(modify-phases ,phases
+           (add-after 'unpack 'fix-cc-name
+             (lambda _
+               (substitute* "utils/hsc2hs/Common.hs"
+                 (("\"cc\"") "\"gcc\""))))
+           (add-after 'unpack-testsuite 'patch-more-shebangs
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((bash (assoc-ref inputs "bash")))
+                 (substitute* '("testsuite/tests/driver/T8602/T8602.script")
+                   (("/bin/sh")
+                    (string-append bash "/bin/sh"))))))
+           (add-after 'skip-more-tests 'skip-even-more-tests
+             (lambda _
+               ;; FIXME: It is unable to find some C header files;
+               ;; setting C_INCLUDE_PATH doesn't help either.
+               (substitute* '("testsuite/tests/driver/T16521/all.T")
+                 (("^.*" all)
+                  (string-append "# guix skipped: " all)))))))))
+    (native-search-paths (list (search-path-specification
+                                (variable "GHC_PACKAGE_PATH")
+                                (files (list
+                                        (string-append "lib/ghc-" version)))
+                                (file-pattern ".*\\.conf\\.d$")
+                                (file-type 'directory))))))
+
 (define-public ghc-8 ghc-8.6)
 
 (define-public ghc ghc-8)