diff mbox series

[bug#69355] gnu: Add libgrapheme.

Message ID 505f3bdf672b32d2d9413ed2e4d83a769518d9ea.1708780937.git.cage-dev@twistfold.it
State New
Headers show
Series [bug#69355] gnu: Add libgrapheme. | expand

Commit Message

cage Feb. 24, 2024, 1:24 p.m. UTC
Change-Id: If19bc5534b8bc3d0aeda4f1e70baa8d42e4948e0
---
 gnu/packages/suckless.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)


base-commit: de24aaf13b17d6c019f3f240fd0eb0e1b8654970
prerequisite-patch-id: aa0b913d42bee51002e7243019d5529984321e91

Comments

Maxim Cournoyer Feb. 26, 2024, 4:24 p.m. UTC | #1
Hi,

cage <cage-dev@twistfold.it> writes:

> Change-Id: If19bc5534b8bc3d0aeda4f1e70baa8d42e4948e0
> ---
>  gnu/packages/suckless.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
> index 81e2151854..e71b0e9252 100644
> --- a/gnu/packages/suckless.scm
> +++ b/gnu/packages/suckless.scm
> @@ -1393,3 +1393,33 @@ (define-public 9base
>      (description
>       "This package provides ported versions of various Plan 9 userland tools
>  for Unix.")))
> +
> +(define-public libgrapheme
> +  (package
> +    (name "libgrapheme")
> +    (version "2.0.2")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://dl.suckless.org/libgrapheme/libgrapheme-"
> +                           version
> +                           ".tar.gz"))
> +       (sha256
> +        (base32 "099i2jm9c25nkbg5420wr12z0gd189gcw5j1ssjmpmbbwzfvv2x6"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     (list #:tests? #f

We strive to enable test suites of packages in Guix, as this gives us a
chance to detect breakage across updates.  Its page mentions a 'test'
target to run the conformance and unit tests of libgrapheme.  Did you
try it, via #:test-target "test" ?  (the default is "check", which is
most common).

> +           #:phases #~(modify-phases %standard-phases
> +                        (add-after 'configure 'post-configure
> +                          (lambda _
> +                            (substitute* "config.mk"

Please leave an explanatory comment mentioning that running ldconfig is
not needed on Guix.

> +                              (("ldconfig") "")))))
> +           #:make-flags
> +           #~(list (string-append "CC=" #$(cc-for-target))
> +                   (string-append "PREFIX=" #$output))))
> +    (home-page "https://libs.suckless.org/libgrapheme/")
> +    (synopsis "Library to handle string according to Unicode standard")
> +    (description "Libgrapheme is an extremely simple freestanding C99 library
> +providing utilities for properly handling strings
> +according to the latest Unicode standard 15.0.0.")

nitpick: The paragraph flow seems broken after 'handling strings' --
"M-;" in Emacs would help.

I'd also drop the exact Unicode standard currently targeted, as this
would probably become outdated information soon.

Could you send a v2 with the above changes?
diff mbox series

Patch

diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 81e2151854..e71b0e9252 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -1393,3 +1393,33 @@  (define-public 9base
     (description
      "This package provides ported versions of various Plan 9 userland tools
 for Unix.")))
+
+(define-public libgrapheme
+  (package
+    (name "libgrapheme")
+    (version "2.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://dl.suckless.org/libgrapheme/libgrapheme-"
+                           version
+                           ".tar.gz"))
+       (sha256
+        (base32 "099i2jm9c25nkbg5420wr12z0gd189gcw5j1ssjmpmbbwzfvv2x6"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:tests? #f
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'configure 'post-configure
+                          (lambda _
+                            (substitute* "config.mk"
+                              (("ldconfig") "")))))
+           #:make-flags
+           #~(list (string-append "CC=" #$(cc-for-target))
+                   (string-append "PREFIX=" #$output))))
+    (home-page "https://libs.suckless.org/libgrapheme/")
+    (synopsis "Library to handle string according to Unicode standard")
+    (description "Libgrapheme is an extremely simple freestanding C99 library
+providing utilities for properly handling strings
+according to the latest Unicode standard 15.0.0.")
+    (license license:isc)))