[bug#78535] gnu: Add networkmanager-dmenu.
Commit Message
* gnu/packages/networking.scm (networkmanager-dmenu): New variable.
Change-Id: Id90b5e2190d2fe6417bee4dfb5b2de0ad5c33d54
---
gnu/packages/networking.scm | 50 +++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)
base-commit: 11bc17c409d77cd1af91e30b5b9f6a73f873a152
@@ -67,6 +67,7 @@
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2025 Sughosha <sughosha@disroot.org>
;;; Copyright © 2025 B. Wilson <elaexuotee@wilsonb.com>
+;;; Copyright © 2025 Junker <dk@junkeria.club>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1059,6 +1060,55 @@ (define-public blueman
(home-page "https://github.com/blueman-project/blueman")
(license license:gpl3+)))
+(define-public networkmanager-dmenu
+ (package
+ (name "networkmanager-dmenu")
+ (version "2.6.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/firecat53/networkmanager-dmenu")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00ys374sildafighd19q2mdbmrba283r0x0q0v59lpii3bsr9q1c"))))
+ (build-system copy-build-system)
+ (arguments
+ (list #:install-plan ''(("networkmanager_dmenu" "bin/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'gi-wrap
+ (lambda _
+ (let ((prog (string-append #$output "/bin/networkmanager_dmenu"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+ (wrap-program prog
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))))))))
+ (inputs (list network-manager
+ python
+ bash-minimal))
+ (native-inputs (list gobject-introspection))
+ (home-page "https://github.com/firecat53/networkmanager-dmenu")
+ (synopsis "Dmenu interface for NetworkManager")
+ (description
+ "Manage NetworkManager connections with supported launchers instead of nm-applet.
+Features:
+@itemize
+@item Connect to existing NetworkManager wifi or wired connections
+@item Connect to new wifi connections. Requests passphrase if required
+@item Connect to existing VPN, Wireguard, GSM/WWAN and Bluetooth connections
+@item Enable/Disable wifi, WWAN, bluetooth and networking
+@item Launch nm-connection-editor GUI
+@item Support for multiple wifi adapters
+@item Optional Pinentry support for secure passphrase entry
+@item Delete existing connections
+@item Rescan wifi networks
+@item Uses notify-send for notifications if available
+@item Start/stop/delete existing NetworkManager Hotspots
+@item Show password/QR code for current Wifi network
+@end itemize")
+ (license license:expat)))
+
(define-public nm-tray
(package
(name "nm-tray")