diff mbox series

[bug#55982,2/2] gnu: libjxl: Update to 0.6.1-0.b7076f18.

Message ID 503147c80552e0f4720460e542002f5720033a44.1655233921.git.code@greghogan.com
State Accepted
Headers show
Series Update google-highway. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan June 14, 2022, 7:20 p.m. UTC
* gnu/packages/image.scm (libjxl): Update to 0.6.1-0.b7076f18.
[inputs]: Add gflags.
---
 gnu/packages/image.scm | 100 +++++++++++++++++++++--------------------
 1 file changed, 51 insertions(+), 49 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 5a13ce56b3..a09e27088b 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -80,6 +80,7 @@  (define-module (gnu packages image)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages photo)
+  #:use-module (gnu packages popt)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
@@ -2232,56 +2233,57 @@  (define-public libheif
     (license license:lgpl3+)))
 
 (define-public libjxl
-  (package
-    (name "libjxl")
-    (version "0.6.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/libjxl/libjxl")
-             (commit (string-append "v" version))
-             (recursive? #t)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "17pvc5zgm9az5hfg2p80325f42w3dqspyb03iakrwg9x4n3vjckx"))
-       (modules '((guix build utils)))
-       (snippet
-        ;; Delete the bundles that will not be used.  libjxl bundles LCMS
-        ;; which is in Guix but there is no option to use the system package.
-        ;; This option will be introduced after version 0.6.1 and then we
-        ;; probably won't need to download the submodules.
-        '(begin
-           (for-each (lambda (directory)
-                       (delete-file-recursively
-                        (string-append "third_party/" directory)))
-                     '("brotli" "googletest" "highway"))))))
-    (build-system cmake-build-system)
-    (arguments
-     `(#:configure-flags
-       (list "-DJPEGXL_FORCE_SYSTEM_GTEST=true"
-             "-DJPEGXL_FORCE_SYSTEM_BROTLI=true"
-             ;; "-DJPEGXL_FORCE_SYSTEM_LCMS2=true" ; next version after 0.6.1
-             "-DJPEGXL_FORCE_SYSTEM_HWY=true")))
-    (native-inputs
-     (list asciidoc doxygen googletest pkg-config python))
-    (inputs
-     (list freeglut
-           giflib
-           google-brotli
-           google-highway
-           imath
-           ;; lcms ; next version after 0.6.1
-           libavif
-           libjpeg-turbo
-           libpng
-           libwebp
-           openexr))
-    (home-page "https://github.com/libjxl/libjxl")
-    (synopsis "JPEG XL image format reference implementation")
-    (description "This package contains a reference implementation of JPEG XL
+  (let ((commit "b7076f1869914eee47b3eae107750f3a3ce43a76")
+        (revision "0"))
+    (package
+      (name "libjxl")
+      (version (git-version "0.6.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/libjxl/libjxl")
+               (commit commit)
+               (recursive? #t)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0jx0hkd2nk15mmnzlk7y7fp644w336il7nsnp5yhf14j8zfaiqz8"))
+         (modules '((guix build utils)))
+         (snippet
+          ;; Delete the bundles that will not be used. libjxl bundles LCMS,
+          ;; which is in Guix, but a newer version is required.
+          '(begin
+             (for-each (lambda (directory)
+                         (delete-file-recursively
+                          (string-append "third_party/" directory)))
+                       '("brotli" "googletest" "highway"))))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:configure-flags
+         (list "-DJPEGXL_FORCE_SYSTEM_GTEST=true"
+               "-DJPEGXL_FORCE_SYSTEM_BROTLI=true"
+               ;; "-DJPEGXL_FORCE_SYSTEM_LCMS2=true" ; requires lcms@2.13
+               "-DJPEGXL_FORCE_SYSTEM_HWY=true")))
+      (native-inputs
+       (list asciidoc doxygen googletest pkg-config python))
+      (inputs
+       (list freeglut
+             gflags
+             giflib
+             google-brotli
+             google-highway
+             imath
+             ;; lcms ; requires lcms@2.13
+             libavif
+             libjpeg-turbo
+             libpng
+             libwebp
+             openexr))
+      (home-page "https://github.com/libjxl/libjxl")
+      (synopsis "JPEG XL image format reference implementation")
+      (description "This package contains a reference implementation of JPEG XL
 (encoder and decoder).")
-    (license license:bsd-3)))
+      (license license:bsd-3))))
 
 (define-public mtpaint
   (package