diff mbox series

[bug#52497] gnu: boost-signals2: Update hash

Message ID 502a90e38bb6f5832fb4230c09e8c9d3343be868.1639528799.git.avityazev@posteo.org
State Accepted
Headers show
Series [bug#52497] gnu: boost-signals2: Update hash | expand

Commit Message

Aleksandr Vityazev Dec. 15, 2021, 12:40 a.m. UTC
* gnu/packages/boost (boost-signals2): [source]: Update hash.
---
 gnu/packages/boost.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Tobias Geerinckx-Rice Dec. 15, 2021, 12:57 a.m. UTC | #1
Aleksandr,

Aleksandr Vityazev 写道:
> * gnu/packages/boost (boost-signals2): [source]: Update hash.

Thanks!

Hash changes happen… ‘but they shouldn't’.  Commit messages should 
not imply that they're routine.

The diff is quite significant:

  $ git diff 10b030be782b979509cee15e0f0afde59d2f9581..\
    4a51d6e47230123d413cbecb19eb94f195301b8e | wc -l
  1829

We should record the two commits in the change log.

10b030b is from October 2019.  Boost 1.77.0 wasn't released until 
August 2021[0].

The boost-1.77.0 tag hasn't been moved from 4a51d6e since June 
2021.  It seems likely that upstream creates boost-X.Y.Z tags 
targetting unreleased future Boost versions, moves them freely, 
but stops once that Boost version is released.

That's something we could document in a comment, at least.

I'll ask for confirmation on their bug tracker.

Only two formatting nitpicks:

> gnu: boost-signals2: Update hash

Missing ‘.’.

> * gnu/packages/boost (boost-signals2): [source]: Update hash.

Drop the first ‘: ’.

Pushed as 04b6e1ed265e64a004c7ea93018179785b979f31 with those 
changes.

Kind regards,

T G-R

[0]: https://lists.boost.org/boost-announce/2021/08/0593.php
diff mbox series

Patch

diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 53815c0268..dab3abffab 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -406,7 +407,7 @@  (define-public boost-signals2
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "13i5j43nggb46i6qpaf7gk53i7zp7pimphl7sydyfqz2m9yx5cdy"))))
+                "1prhj98jgvkj2m3ia5lcgxnl1a4h13cyzqd55skjn983rivi6090"))))
     (build-system trivial-build-system)
     (arguments
      `(#:modules ((guix build utils))