diff mbox series

[bug#49917,core-updates-frozen] gnu: go-1.14: Fix test failure with GCC 9+.

Message ID 5018c60ab22041bac940e7828fe197efcf8167e7.1628285642.git.iskarian@mgsn.dev
State Accepted
Headers show
Series [bug#49917,core-updates-frozen] gnu: go-1.14: Fix test failure with GCC 9+. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Aug. 6, 2021, 9:40 p.m. UTC
With GCC 9+, go-1.14 fails a test when the gold linker is not
available (https://github.com/golang/go/issues/39157). Backport the fix
for that from https://github.com/golang/go/commit/4ec4a79.

gnu/packages/golang.scm (go-1.14)[arguments]<#:phases>{prebuild}:
Fix test failure with GCC 9+.
---
Hello Guix,

This fixes the CI failure at

  https://ci.guix.gnu.org/build/725502/details

and probably for other platforms as well. This should also probably go to
core-updates.

--
Sarah

 gnu/packages/golang.scm | 5 +++++
 1 file changed, 5 insertions(+)


base-commit: b2a5a180cfa56e55bc8078d606a971e34e326967

Comments

Efraim Flashner Aug. 8, 2021, 12:14 p.m. UTC | #1
Thanks. Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d3ef39a2e6..cbcd9adb4c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1247,6 +1247,11 @@  in the style of communicating sequential processes (@dfn{CSP}).")
                    (("/bin/pwd") (which "pwd"))
                    (("/bin/sh") (which "sh")))
 
+                 ;; Backport fix for go-1.14 with GCC 9+
+                 ;; https://github.com/golang/go/issues/39157
+                 (substitute* "cmd/go/note_test.go"
+                   (("cannot find 'ld'") "cannot find [‘']ld[’']"))
+
                  ;; Add libgcc to runpath
                  (substitute* "cmd/link/internal/ld/lib.go"
                    (("!rpath.set") "true"))