diff mbox series

[bug#74495,03/16] gnu: Add go-github-com-makenowjust-heredoc.

Message ID 500edbbd5f088ad65b0b53d33cbc108c99ce00d3.1732386154.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-noahgorstein-jqp. | expand

Commit Message

Artyom V. Poptsov Nov. 23, 2024, 6:28 p.m. UTC
* gnu/packages/golang.scm (go-github-com-makenowjust-heredoc): New variable.

Change-Id: I686dfd6a798da764b004a53a562ca788e70f8cd5
---
 gnu/packages/golang-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b050c285f3..50f358ad58 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4832,6 +4832,29 @@  (define-public go-github-com-logrusorgru-aurora-v4
     (native-inputs
      (list go-github-com-stretchr-testify))))
 
+(define-public go-github-com-makenowjust-heredoc
+  (package
+    (name "go-github-com-makenowjust-heredoc")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/makenowjust/heredoc")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "18f21zm8n2wlnkz1ylw8rcxmqxyv2rlz8749yfqggm2m0m2884pj"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/MakeNowJust/heredoc"))
+    (home-page "https://github.com/MakeNowJust/heredoc")
+    (synopsis "Here-documents with indent")
+    (description
+     "Package heredoc provides creation of here-documents from raw strings.")
+    (license license:expat)))
+
 (define-public go-github-com-marcinbor85-gohex
   ;; No release, see <https://github.com/marcinbor85/gohex/issues/5>.
   (let ((commit "baab2527a9a2a4abb3dc06baabedfa5e0268b8d8")