diff mbox series

[bug#49412,core-updates] gnu: libdrm: Update to 2.4.107.

Message ID 4s2tn7of6SN9mqU6sdllttaKyg4DEmnQh7R0axEJc@cp3-web-047.plabs.ch
State Accepted
Headers show
Series [bug#49412,core-updates] gnu: libdrm: Update to 2.4.107. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Kaelyn Takata July 5, 2021, 8:43 a.m. UTC
* gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
libpciaccess to a propagated input as the pkg-config for libdrm_intel now
includes it in the libs.
---
 gnu/packages/xdisorg.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

M July 5, 2021, 3:15 p.m. UTC | #1
Kaelyn Takata via Guix-patches via schreef op ma 05-07-2021 om 08:43 [+0000]:
> * gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
> libpciaccess to a propagated input as the pkg-config for libdrm_intel now
> includes it in the libs.
> ---
>  gnu/packages/xdisorg.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> index d0da2d28d1..1b38149654 100644
> --- a/gnu/packages/xdisorg.scm
> +++ b/gnu/packages/xdisorg.scm
> @@ -638,7 +638,7 @@ rasterisation.")
>  (define-public libdrm
>    (package
>      (name "libdrm")
> -    (version "2.4.104")
> +    (version "2.4.107")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append
> @@ -646,7 +646,7 @@ rasterisation.")
>                      version ".tar.xz"))
>                (sha256
>                 (base32
> -                "1jqvx9c23hgwhq109zqj6vg3ng40pcvh3r1k2fn1a424qasxhsnn"))))
> +                "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
>      (build-system meson-build-system)
>      (arguments
>       `(#:configure-flags
> @@ -663,7 +663,7 @@ rasterisation.")
>                    (replace 'check
>                      (lambda _
>                        (invoke "meson" "test" "--timeout-multiplier" "5"))))))

If you are updating "libdrm" on core-updates anyway,
can you also make the following change (as a separate patch)?:

(replace 'check
  (lambda* (#:key tests? #:allow-other-keys)
    (when tests?
      (invoke "meson" "test" "--timeout-multiplier" 5))))

That should allow "guix build SOMETHING --without-tests=libdrm" to work.

Greetings,
Maxime.
Kaelyn Takata July 5, 2021, 3:58 p.m. UTC | #2
On Monday, July 5th, 2021 at 11:15 AM, Maxime Devos <maximedevos@telenet.be> wrote:

> Kaelyn Takata via Guix-patches via schreef op ma 05-07-2021 om 08:43 [+0000]:
>
> > -   gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
> >
> >     libpciaccess to a propagated input as the pkg-config for libdrm_intel now
> >
> >     includes it in the libs.
> >
> > gnu/packages/xdisorg.scm | 6 +++---
> >
> > 1 file changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> >
> > index d0da2d28d1..1b38149654 100644
> >
> > --- a/gnu/packages/xdisorg.scm
> >
> > +++ b/gnu/packages/xdisorg.scm
> >
> > @@ -638,7 +638,7 @@ rasterisation.")
> >
> > (define-public libdrm
> >
> > (package
> >
> > (name "libdrm")
> >
> > -   (version "2.4.104")
> >
> > -   (version "2.4.107")
> >
> >     (source (origin
> >
> >     (method url-fetch)
> >
> >     (uri (string-append
> >
> >     @@ -646,7 +646,7 @@ rasterisation.")
> >
> >     version ".tar.xz"))
> >
> >     (sha256
> >
> >     (base32
> >
> > -                  "1jqvx9c23hgwhq109zqj6vg3ng40pcvh3r1k2fn1a424qasxhsnn"))))
> >
> >
> >
> > -                  "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
> >
> >
> >     (build-system meson-build-system)
> >
> >     (arguments
> >
> >     `(#:configure-flags
> >
> >     @@ -663,7 +663,7 @@ rasterisation.")
> >
> >     (replace 'check
> >
> >     (lambda _
> >
> >     (invoke "meson" "test" "--timeout-multiplier" "5"))))))
>
> If you are updating "libdrm" on core-updates anyway,
>
> can you also make the following change (as a separate patch)?:
>
> (replace 'check
>
> (lambda* (#:key tests? #:allow-other-keys)
>
> (when tests?
>
> (invoke "meson" "test" "--timeout-multiplier" 5))))
>
> That should allow "guix build SOMETHING --without-tests=libdrm" to work.

I'm not familiar with the "--without-tests=" flag and mechanism, but would be happy to add a patch for it. I've only recently started using Guix and this is my first patch submission (it's a precursor patch from my attempt to update mesa to 21.1.x); should I email that patch to 49412@debbugs.gnu.org to make it part of the same issue?

Cheers,
Kaelyn
John Kehayias July 5, 2021, 9:58 p.m. UTC | #3
With regards to updating Mesa, please see the issue below for work on that (looks like some packages will have be updated with the new Mesa, too):

https://issues.guix.gnu.org/49339
M July 6, 2021, 8:24 a.m. UTC | #4
Kaelyn schreef op ma 05-07-2021 om 15:58 [+0000]:
> [...]
> I'm not familiar with the "--without-tests=" flag and mechanism, but would be happy
> to add a patch for it. I've only recently started using Guix and this is my first
> patch submission (it's a precursor patch from my attempt to update mesa to 21.1.x);
> should I email that patch to 49412@debbugs.gnu.org to make it part of the same issue?

If you mean the 'when tests?' patch, then I'd send it to 49412@debbugs.gnu.org
to keep the libdrm patches together (maybe as a v2 patch series).  If you mean
‘updating mesa to 21.1.1x’, then I'd send that patch to guix-patches@gnu.org,
as updating 'mesa' seems much more complicated than only updating 'libdrm'
(see reply by John Kehayias).

There is some documentation in the chapter ‘16 Contributing’ in the manual
on the process (more specifically, the section ‘16.6 Submitting Patches’)
but it doesn't have much advice on when to split patch series ...

Greetings,
Maxime.
John Kehayias July 8, 2021, 3:02 a.m. UTC | #5
> If you mean the 'when tests?' patch, then I'd send it to 49412@debbugs.gnu.orgto keep the libdrm patches together (maybe as a v2 patch series).  If you mean‘updating mesa to 21.1.1x’, then I'd send that patch to guix-patches@gnu.org,as updating 'mesa' seems much more complicated than only updating 'libdrm'(see reply by John Kehayias).

Just to follow up here, I think Mesa can be updated pretty simply too, as the original Mesa patch referenced also enabled libglvnd. I've followed up on both the original patch submission and on guix-devel (to gather feedback on moving things to libglvnd).
John Kehayias July 8, 2021, 3:43 p.m. UTC | #6
I've updated the Mesa patch over at https://issues.guix.gnu.org/49339 to just do a minimal version bump and not touch libdrm, relying on this patch for that. So it would be great to get this libdrm update merged so we can move ahead with Mesa to 21.1.4.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d0da2d28d1..1b38149654 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -638,7 +638,7 @@  rasterisation.")
 (define-public libdrm
   (package
     (name "libdrm")
-    (version "2.4.104")
+    (version "2.4.107")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -646,7 +646,7 @@  rasterisation.")
                     version ".tar.xz"))
               (sha256
                (base32
-                "1jqvx9c23hgwhq109zqj6vg3ng40pcvh3r1k2fn1a424qasxhsnn"))))
+                "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags
@@ -663,7 +663,7 @@  rasterisation.")
                   (replace 'check
                     (lambda _
                       (invoke "meson" "test" "--timeout-multiplier" "5"))))))
-    (inputs
+    (propagated-inputs
      `(("libpciaccess" ,libpciaccess)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))