diff mbox series

[bug#52526,xdot:,fix,typelib,path]

Message ID 4fff3bbd-b815-2e02-6685-82ee1e2bb135@cock.li
State Accepted
Headers show
Series [bug#52526,xdot:,fix,typelib,path] | expand

Commit Message

Justin Veilleux Dec. 15, 2021, 10:10 p.m. UTC
Before this change, xdot simply crashed on launch.

Comments

Leo Famulari Dec. 15, 2021, 10:41 p.m. UTC | #1
On Wed, Dec 15, 2021 at 05:10:03PM -0500, Justin Veilleux wrote:
> Before this change, xdot simply crashed on launch.

> From 4fe39e9958fb446e0d26eaa2668d15c706fc4f88 Mon Sep 17 00:00:00 2001
> From: terramorpha <terramorpha@cock.li>
> Date: Wed, 15 Dec 2021 17:01:02 -0500
> Subject: [PATCH] gnu: xdot: Add harfbuzz Typelib path in wrap phase
> 
> * gnu/packages/graphviz.scm (xdot)[#:phases]: Add harfbuzz's path to the
> wrapper.

Thanks! Pushed as 18b1497673b92b6a0947839f9757a561a77d0d5f
diff mbox series

Patch

From 4fe39e9958fb446e0d26eaa2668d15c706fc4f88 Mon Sep 17 00:00:00 2001
From: terramorpha <terramorpha@cock.li>
Date: Wed, 15 Dec 2021 17:01:02 -0500
Subject: [PATCH] gnu: xdot: Add harfbuzz Typelib path in wrap phase

* gnu/packages/graphviz.scm (xdot)[#:phases]: Add harfbuzz's path to the
wrapper.
---
 gnu/packages/graphviz.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index c4dfd4965b..ab39e49d7d 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2020 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;; Copyright © 2021 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -346,12 +347,14 @@  (define-public xdot
                     (assoc-ref inputs "gtk+") "/lib/girepository-1.0"
                     ":" (assoc-ref inputs "pango") "/lib/girepository-1.0"
                     ":" (assoc-ref inputs "gdk-pixbuf") "/lib/girepository-1.0"
-                    ":" (assoc-ref inputs "atk") "/lib/girepository-1.0")))
+                    ":" (assoc-ref inputs "atk") "/lib/girepository-1.0"
+                    ":" (assoc-ref inputs "harfbuzz") "/lib/girepository-1.0")))
                `("PATH" ":" prefix
                  (,(dirname (search-input-file inputs "bin/dot"))))))))))
     (inputs
      (list atk
            librsvg
+           harfbuzz
            graphviz
            gtk+
            python-pycairo
-- 
2.34.0