diff mbox series

[bug#44977] gnu: bc: Fix readline support.

Message ID 4fddf8d02cdc75a6e1ada39385702f68f80f189f.camel@free.fr
State Accepted
Headers show
Series [bug#44977] gnu: bc: Fix readline support. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

dftxbs3e Dec. 1, 2020, 1:31 a.m. UTC
Fix typo in path.
diff mbox series

Patch

From ba427730bb61e7d8270a3c71ce36f631d8227bbd Mon Sep 17 00:00:00 2001
From: John Doe <dftxbs3e@free.fr>
Date: Tue, 1 Dec 2020 02:15:20 +0100
Subject: [PATCH] gnu: bc: Fix readline support.

--with-readline is given to configure but there's no readline input
present so it is not effective. Probably bc's configure should fail when
that is the case but that's another story.

* gnu/packages/algebra.scm (bc)[inputs]: Add readline.
---
 gnu/packages/algebra.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 5b391449a0..ea2ec6f1ef 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -710,6 +710,8 @@  binary.")
                "0amh9ik44jfg66csyvf4zz1l878c4755kjndq9j0270akflgrbb2"))
              (patches (search-patches "bc-fix-cross-compilation.patch"))))
     (build-system gnu-build-system)
+    (inputs
+     `(("readline" ,readline)))
     (native-inputs
      `(("automake" ,automake)
        ("autoconf" ,autoconf)
-- 
2.28.0