diff mbox series

[bug#63296] gnu: Add capnproto-0.9

Message ID 4fb8c652-b8dd-4be9-bdf4-7abbc0ed29b0@pantherx.org
State New
Headers show
Series [bug#63296] gnu: Add capnproto-0.9 | expand

Commit Message

Franz Geffke May 5, 2023, 10:31 a.m. UTC
(name "python-ruamel.yaml")

Comments

Ludovic Courtès May 11, 2023, 1:42 p.m. UTC | #1
Hi Franz,

Franz Geffke <franz@pantherx.org> skribis:

> diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
> index 39954d6764..d0b44f7709 100644
> --- a/gnu/packages/serialization.scm
> +++ b/gnu/packages/serialization.scm
> @@ -613,6 +613,20 @@ (define-public capnproto
>  RPC system.  Think JSON, except binary.  Or think Protocol Buffers,
>  except faster.")
>      (license license:expat)))
>
> +(define-public capnproto-0.9

Are there packages in Guix that are going to depend on it?

If not, could you explain briefly why we should have it?

In general, we keep old versions if there’s a package depending on it or
if there’s a strong use case (for example, developers may often work
with different versions of Python, GCC, or LLVM, so we keep several
versions of them).

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 39954d6764..d0b44f7709 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -613,6 +613,20 @@  (define-public capnproto
  RPC system.  Think JSON, except binary.  Or think Protocol Buffers, except 
faster.")
      (license license:expat)))

+(define-public capnproto-0.9
+  (package
+    (inherit capnproto)
+    (name "capnproto")
+    (version "0.9.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://capnproto.org/capnproto-c++-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0hi5lpyhskdg99n9zgn0ffr79gn12m1j7igkp9wikklg2p4yjca0"))))))
+
  (define-public python-ruamel.yaml
    (package