[bug#77568,ruby-team,1/3] gnu: ruby-test-unit: Simplify testing.
Commit Message
* gnu/packages/ruby.scm (ruby-test-unit): Simplify testing by directly running
the test script and removing redundant native input dependencies.
Change-Id: I8ceb7c46dffade84d00fe6477210d808b3012f60
---
gnu/packages/ruby.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)
@@ -5155,10 +5155,16 @@ (define-public ruby-test-unit
(base32
"0w1m432q3y5v9lkak8yyxadak3z17bsp6afni97i4zjdgfz7niz2"))))
(build-system ruby-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ruby" "test/run.rb")))))))
(propagated-inputs
(list ruby-power-assert))
- (native-inputs
- (list bundler ruby-packnga ruby-yard))
(synopsis "Unit testing framework for Ruby")
(description "@code{Test::Unit} is unit testing framework for Ruby, based
on xUnit principles. These were originally designed by Kent Beck, creator of