[bug#76480,33/51] gnu: python-specreduce: Simplify.

Message ID 4f6b36ec9be9fd47eefcc13cad7414ed6f85dc36.1740173176.git.sharlatanus@gmail.com
State New
Headers
Series Astro update 2025/02 |

Commit Message

Sharlatan Hellseher Feb. 21, 2025, 9:49 p.m. UTC
  * gnu/packages/astronomy.scm (python-specreduce) [arguments] <phases>:
Remove 'patch-pyproject-toml.
[native-inputs]: Remove python-setuptools-scm; add
python-setuptools-scm-next.

Change-Id: Ia582574b00bfb5a08a39c8ac8bac591fd661706e
---
 gnu/packages/astronomy.scm | 8 +-------
 1 file changed, 1 insertion(+), 7 deletions(-)
  

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d406bab2717..9df3e2f828f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3566,12 +3566,6 @@  (define-public python-specreduce
                     " and not specreduce.calibration_data.get_reference_file_path"))
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'patch-pypojrect-toml
-            (lambda _
-              (substitute* "pyproject.toml"
-                ;; TypeError: Configuration.__init__() got an unexpected
-                ;; keyword argument 'version_file'
-                (("version_file = .*") ""))))
          (add-before 'check 'set-home
            (lambda _
              ;; Relax matplotlib warning: ... because the default path
@@ -3581,7 +3575,7 @@  (define-public python-specreduce
     (native-inputs
      (list python-photutils
            python-pytest-astropy
-           python-setuptools-scm
+           python-setuptools-scm-next
            python-wheel))
     (propagated-inputs
      (list python-astropy