[bug#67970,v2] gnu: python-pdfminer-six: Update to 20231228.
Commit Message
* gnu/packages/python-xyz.scm (python-pdfminer-six): Update to 20231228.
[build-system]: Use pyproject-build-system.
[arguments]: Convert to gexp and remove custom 'check phase.
[propagated-inputs]: Remove python-chardet and python-sortedcontainers;
add python-charset-normalizer.
[native-inputs]: Remove python-nose and python-tox; add python-pytest.
Change-Id: I9913385a681b32afde930e32e7379db91357177b
---
gnu/packages/python-xyz.scm | 26 +++++++++++---------------
1 file changed, 11 insertions(+), 15 deletions(-)
base-commit: bc8a41f4a8d9f1f0525d7bc97c67ed3c8aea3111
@@ -19926,7 +19926,7 @@ (define-public python-jellyfish
(define-public python-pdfminer-six
(package
(name "python-pdfminer-six")
- (version "20201018")
+ (version "20231228")
;; There are no tests in the PyPI tarball.
(source
(origin
@@ -19936,23 +19936,19 @@ (define-public python-pdfminer-six
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1a2fxxnnjqbx344znpvx7cnv1881dk6585ibw01inhfq3w6yj2lr"))))
- (build-system python-build-system)
+ (base32 "1anyr0gm7amwls8qifflql1viz5rq6q95lfwcg43v3180h4w8wrd"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Tests write to the source tree.
- (add-after 'unpack 'make-git-checkout-writable
- (lambda _
- (for-each make-file-writable (find-files "."))
- #t))
- (replace 'check
- (lambda _
- (invoke "make" "test"))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; Tests write to the source tree.
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files ".")))))))
(propagated-inputs
- (list python-chardet python-cryptography python-sortedcontainers))
+ (list python-charset-normalizer python-cryptography))
(native-inputs
- (list python-nose python-tox))
+ (list python-pytest))
(home-page "https://github.com/pdfminer/pdfminer.six")
(synopsis "PDF parser and analyzer")
(description "@code{pdfminer.six} is a community maintained fork of