diff mbox series

[bug#71997,core-updates] gnu: gd: Skip failing test on i686-linux.

Message ID 4f2316fd90495dff085061ff05cb001d8de63a87.1720444887.git.ludo@gnu.org
State New
Headers show
Series [bug#71997,core-updates] gnu: gd: Skip failing test on i686-linux. | expand

Commit Message

Ludovic Courtès July 8, 2024, 1:21 p.m. UTC
* gnu/packages/gd.scm (gd)[arguments]: Add “XFAIL_TESTS” to #:make-flags
on i686-linux.

Change-Id: I52a9cfeb352b0ec3fce4ff1f82f43c5f7bef6ef0
---
 gnu/packages/gd.scm | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)


base-commit: e4da066f0029ef38f6a791f6f9d4cfdb8b39b6a3
diff mbox series

Patch

diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 2c5ba599154..98d34cfa71e 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -1,5 +1,5 @@ 
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2016, 2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2016, 2023-2024 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
@@ -61,7 +61,15 @@  (define-public gd
     (arguments
      ;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
      ;; issues on aarch64 and other architectures.
-     (list #:make-flags #~(list "CFLAGS=-ffp-contract=off")
+     (list #:make-flags #~(list "CFLAGS=-ffp-contract=off"
+
+                                ;; XXX: This test fails on i686-linux.
+                                ;; See <https://issues.guix.gnu.org/71996>.
+                                #$@(if (and (not (%current-target-system))
+                                            (string-prefix? "i686"
+                                                            (%current-system)))
+                                       #~("XFAIL_TESTS=gdimagegrayscale/basic")
+                                       #~()))
            #:configure-flags #~(list "--disable-static")
            #:phases
            #~(modify-phases %standard-phases