diff mbox series

[bug#47913] add netdiscover

Message ID 4ecb12dc6ad26ca9874b46784fad0119@cock.li
State Accepted
Headers show
Series [bug#47913] add netdiscover | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Justin Veilleux April 20, 2021, 5:47 p.m. UTC
---
  gnu/packages/networking.scm | 26 ++++++++++++++++++++++++++
  1 file changed, 26 insertions(+)

mainly for
+those wireless networks without dhcp server, it also works on 
hub/switched
+networks.  Its based on arp packets, it will send arp requests and 
sniff for
+replies.")
+   (home-page "https://github.com/netdiscover-scanner/netdiscover")
+   (license license:gpl3)))

Comments

M April 20, 2021, 6:29 p.m. UTC | #1
terramorpha@cock.li schreef op di 20-04-2021 om 13:47 [-0400]:
> [...]
> +   (home-page "https://github.com/netdiscover-scanner/netdiscover")
> +   (license license:gpl3)))
Fr-
om netdiscover/src/data_ai.h:

 *  This program is free software; you can redistribute it and/or modify
 *  it under the terms of the GNU General Public License as published by
 *  the Free Software Foundation; either version 3 of the License, or
 *  (at your option) any later version.

So this should perhaps be license:gpl3+?
 
Greetings,
Maxime.
Justin Veilleux April 20, 2021, 8:26 p.m. UTC | #2
That makes sense. Should I send another patch with this field fixed ?

On April 20, 2021 2:29:24 p.m. EDT, Maxime Devos <maximedevos@telenet.be> wrote:
>terramorpha@cock.li schreef op di 20-04-2021 om 13:47 [-0400]:
>> [...]
>> +   (home-page "https://github.com/netdiscover-scanner/netdiscover")
>> +   (license license:gpl3)))
>Fr-
>om netdiscover/src/data_ai.h:
>
> *  This program is free software; you can redistribute it and/or modify
> *  it under the terms of the GNU General Public License as published by
> *  the Free Software Foundation; either version 3 of the License, or
> *  (at your option) any later version.
>
>So this should perhaps be license:gpl3+?
> 
>Greetings,
>Maxime.
Justin Veilleux April 27, 2021, 3:52 p.m. UTC | #3
Are there still issues preventing the patch from being merged?
M April 27, 2021, 6:19 p.m. UTC | #4
terramorpha@cock.li schreef op di 27-04-2021 om 11:52 [-0400]:
> Are there still issues preventing the patch from being merged?

None that I know of.  You'll have to wait for a committer (which I am not)
to confirm and merge the patch.

Note: I reviewed the patch, but didn't test the package.

Greetings,
Maxime.
Justin Veilleux July 9, 2021, 9:07 p.m. UTC | #5
Could someone with commit access take a look at my patch ?
Arun Isaac July 10, 2021, 9:51 a.m. UTC | #6
Hi Justin,

Thank you for contributing to Guix! I applied your patch with a few
corrections:

- changed commit message to conform to Guix conventions
- added a copyright header for you
- made some stylistic changes to the package description
- modified the description slightly

Thanks,
Arun
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f7557fc331..342621299b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4075,3 +4075,29 @@  IPv6 Internet connectivity - it also works over 
IPv4.")
       ;; version. This exception does not (and cannot) modify any 
license terms
       ;; which apply to the Application, with which you must still 
comply
       license:lgpl3)))
+
+(define-public netdiscover
+  (package
+   (name "netdiscover")
+   (version "0.7")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url 
"https://github.com/netdiscover-scanner/netdiscover")
+                  (commit version)))
+            (sha256 (base32 
"0g8w8rlg16dsibxi4dnyn7v7r8wwi5ypd51c4w59j0ps2id0w8yj"))
+            (file-name (string-append "netdiscover-" version))))
+   (arguments `(#:tests? #f)) ;; no tests
+   (build-system gnu-build-system)
+   (inputs `(("libpcap" ,libpcap)
+             ("libnet" ,libnet)))
+   (native-inputs `(("automake" ,automake)
+                    ("autoconf" ,autoconf)))
+   (synopsis "Network address discovery tool")
+   (description
+    "Netdiscover is a network address discovering tool, developed