diff mbox series

[bug#71781,v4,28/29] gnu: Add mozo.

Message ID 4ea02996774dd28637f3799f71931708511fe3c2.1720684465.git.atai@atai.org
State New
Headers show
Series Update Mate Desktop to 1.28. | expand

Commit Message

Andy Tai July 11, 2024, 7:57 a.m. UTC
* gnu/packages/mate.scm (mozo): New variable.
  (mate)[inputs]: Add mozo.

Change-Id: I317b3479b44b1b02abf814fa5b871faa436913a6
---
 gnu/packages/mate.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 942f572f7d..7eb8847d33 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -1521,6 +1521,33 @@  (define-public mate-polkit-for-xfce
                (rename-file old new)))))))
     (properties `((hidden? . #t)))))
 
+
+(define-public mozo
+  (package
+    (name "mozo")
+    (version "1.28.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://mate/" (version-major+minor version) "/"
+                           "mozo-" version ".tar.xz"))
+       (sha256
+        (base32 "0929yk7g7103d18p400ysi19pqrxl3dyzg4l0mnw7a3azm7ri67y"))))
+    (build-system glib-or-gtk-build-system)
+    (native-inputs
+     (list pkg-config))
+    (inputs
+     (list gettext-minimal
+           mate-menus
+           python
+           python-pygobject))
+    (home-page "https://mate-desktop.org/")
+    (synopsis "Menu editor for MATE")
+    (description "Mozo is a menu editor for MATE using the freedesktop.org menu
+specification")
+    (license (list license:lgpl2.0+))))
+
+
 (define-public mate
   (package
     (name "mate")
@@ -1579,6 +1606,7 @@  (define-public mate
                    mate-polkit
                    mate-system-monitor
                    mate-utils
+                   mozo
                    pluma
                    pinentry-gnome3
                    pulseaudio