From: 宋文武 <iyzsong@member.fsf.org>
* gnu/packages/xorg.scm (xcb-util-errors): Update to 1.0.1.
Change-Id: I43b48895b9654df48bbc9898f702e24b401c8e16
---
gnu/packages/xorg.scm | 72 +++++++++++++++++--------------------------
1 file changed, 28 insertions(+), 44 deletions(-)
@@ -5599,49 +5599,33 @@ (define-public xcb-util-cursor
"See COPYING in the distribution."))))
(define-public xcb-util-errors
- (let ((commit "5d660ebe872cadcdc85de9d6f9afe05de629c030")
- (revision "1"))
- (package
- (name "xcb-util-errors")
- (version (git-version "1.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://anongit.freedesktop.org/git/xcb/util-errors.git")
- (commit commit)
- (recursive? #t)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "12bah0iz5k6b9hwlc5zffyfg2gnrajll3gn5s8zmazgynvw72ahg"))))
- (build-system gnu-build-system)
- (outputs '("out"))
- (inputs
- (list util-macros xcb-proto))
- (propagated-inputs
- (list libxcb))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("python" ,python-wrapper)
- ("pkg-config" ,pkg-config)
- ,@(if (%current-target-system)
- `(("libxcb" ,libxcb))
- `())))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'bootstrap
- (lambda _
- ;; The default 'bootstrap' phase would run 'autogen.sh', which
- ;; would try to run ./configure and fail due to unpatched
- ;; shebangs.
- (invoke "autoreconf" "-v" "--install"))))))
- (home-page "https://cgit.freedesktop.org/xcb/util-errors/")
- (synopsis "XCB helper library for printing information about X11 errors")
- (description
- "The XCB util module provides a number of libraries which sit on
+ (package
+ (name "xcb-util-errors")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://xcb.freedesktop.org/dist/"
+ "xcb-util-errors-" version ".tar.xz"))
+ (sha256
+ (base32 "0mzkh3xj1n690dw8hrdhyjykd71ib0ls9n5cgf9asna2k1xwha2n"))))
+ (build-system gnu-build-system)
+ (outputs '("out"))
+ (inputs
+ (list util-macros xcb-proto))
+ (propagated-inputs
+ (list libxcb))
+ (native-inputs
+ `(("m4" ,m4)
+ ("python" ,python-wrapper)
+ ("pkg-config" ,pkg-config)
+ ,@(if (%current-target-system)
+ `(("libxcb" ,libxcb))
+ `())))
+ (home-page "https://cgit.freedesktop.org/xcb/util-errors/")
+ (synopsis "XCB helper library for printing information about X11 errors")
+ (description
+ "The XCB util module provides a number of libraries which sit on
top of libxcb, the core X protocol library, and some of the extension
libraries. These experimental libraries provide convenience functions
and interfaces which make the raw X protocol more usable. Some of the
@@ -5651,7 +5635,7 @@ (define-public xcb-util-errors
The XCB util-errors module provides a utility library that gives human
readable names to error codes, event codes, and also to major and minor
numbers.")
- (license license:x11))))
+ (license license:x11)))
(define-public xcb-util-image
(package