diff mbox series

[bug#64633] gnu: Add wdisplays.

Message ID 4e8847021ede6d8eac1bcfb8bb64583d61346a80.1689387515.git.kiasoc5@disroot.org
State New
Headers show
Series [bug#64633] gnu: Add wdisplays. | expand

Commit Message

kiasoc5 July 15, 2023, 2:18 a.m. UTC
* gnu/packages/wm.scm (wdisplays): New variable.
---
 gnu/packages/wm.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 917a299831361f253ea664f009176b4bbe06900a

Comments

宋文武 July 20, 2023, 11:12 a.m. UTC | #1
Hello kiasoc5, this is a good patch and QA passed, so I applied it with
synopsis and description adjusted:

-    (synopsis "Graphical application for configuring displays in Wayland compositors")
-    (description "wdisplays is a graphical application for configuring displays in
-Wayland compositors that implements the wlr-output-management-unstable-v1 protocol.")
+    (synopsis "Configuring displays in Wayland compositors")
+    (description "@command{wdisplays} is a graphical application for
+configuring displays in Wayland compositors that implements the

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b9909de219..56a0b72236 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2022,6 +2022,28 @@  (define-public kanshi
 Wayland compositors supporting the wlr-output-management protocol.")
     (license license:expat))) ; MIT license
 
+(define-public wdisplays
+  (package
+    (name "wdisplays")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/artizirk/wdisplays.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "06ydcmfdics2qqjb14p767xs8khd86nancdd9z8j11h2gpvwznvn"))))
+    (build-system meson-build-system)
+    (inputs (list gtk+ libepoxy wayland))
+    (native-inputs (list `(,glib "bin") pkg-config))
+    (home-page "https://github.com/artizirk/wdisplays")
+    (synopsis "Graphical application for configuring displays in Wayland compositors")
+    (description "wdisplays is a graphical application for configuring displays in
+Wayland compositors that implements the wlr-output-management-unstable-v1 protocol.")
+    (license license:gpl3+)))
+
 (define-public stumpwm
   (package
     (name "stumpwm")