[bug#77949,v2,3/3] gnu: neovim: Update to 0.11.0.
Commit Message
* gnu/packages/vim.scm (neovim): Update to 0.11.0.
Change-Id: I278b533b2ff13e2b40652ce451c9924fc729df5a
---
gnu/packages/vim.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
@@ -16,6 +16,7 @@
;;; Copyright © 2023 Charles Jackson <charles.b.jackson@protonmail.com>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2023, 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
+;;; Copyright © 2025 John Khoo <johnkhootf@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -79,6 +80,7 @@ (define-module (gnu packages vim)
#:use-module (gnu packages shells)
#:use-module (gnu packages tcl)
#:use-module (gnu packages text-editors)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages terminals)
#:use-module (gnu packages tree-sitter)
#:use-module (gnu packages xdisorg)
@@ -782,7 +784,7 @@ (define-public neovim-packer
(define-public neovim
(package
(name "neovim")
- (version "0.9.5")
+ (version "0.11.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -791,7 +793,7 @@ (define-public neovim
(file-name (git-file-name name version))
(sha256
(base32
- "1j3z7jay0m6g06v04falrzr062g07xr4svbrc3hywlqi2h6rrvk5"))))
+ "1z7xmngjr93dc52k8d3r6x0ivznpa8jbdrw24gqm16lg9gzvma02"))))
(build-system cmake-build-system)
(arguments
(list #:modules
@@ -849,6 +851,7 @@ (define-public neovim
libtermkey
libvterm
unibilium
+ utf8proc
jemalloc
(if (member (if (%current-target-system)
(gnu-triplet->nix-system (%current-target-system))