diff mbox series

[bug#74234,PATCHv2,rust-team,17/20] gnu: Add rust-roxmltree-0.20.

Message ID 4e80e54f829777bbac70f26a2e5902bbb94aedd1.1731018437.git.goodoldpaul@autistici.org
State New
Headers show
Series [bug#74234,PATCHv2,rust-team,01/20] gnu: Add rust-ashpd-0.6. | expand

Commit Message

Giacomo Leidi Nov. 7, 2024, 10:27 p.m. UTC
* gnu/packages/crates-io.scm (rust-roxmltree-0.20): New variable.

Change-Id: I24093e4999827360f1aa84fc7c3c232a409698d3
---
 gnu/packages/crates-io.scm | 19 ++++++++++++++++---
 1 file changed, 16 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d79dffc775..70744babf9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65817,17 +65817,17 @@  (define-public rust-rowan-0.15
      "This package provides a library for generic lossless syntax trees.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-roxmltree-0.19
+(define-public rust-roxmltree-0.20
   (package
     (name "rust-roxmltree")
-    (version "0.19.0")
+    (version "0.20.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "roxmltree" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "0zs0q8hg5nnh91s1ib6r0fky7xm8ay63ayfa5i1afxxpwgalzl9w"))))
+        (base32 "15vw91ps91wkmmgy62khf9zb63bdinvm80957dascbsw7dwvc83c"))))
     (build-system cargo-build-system)
     (home-page "https://github.com/RazrFalcon/roxmltree")
     (synopsis "Represent an XML as a read-only tree")
@@ -65835,6 +65835,19 @@  (define-public rust-roxmltree-0.19
      "@code{roxmltree} represents an XML 1.0 document as a read-only tree.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-roxmltree-0.19
+  (package
+    (inherit rust-roxmltree-0.20)
+    (name "rust-roxmltree")
+    (version "0.19.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "roxmltree" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0zs0q8hg5nnh91s1ib6r0fky7xm8ay63ayfa5i1afxxpwgalzl9w"))))))
+
 (define-public rust-roxmltree-0.14
   (package
     (inherit rust-roxmltree-0.19)