diff mbox series

[bug#67434,1/3] gnu: Add ghc-bimap

Message ID 4e7f776c-9464-013b-ecd3-e89c8f7efdf8@mailbox.org
State New
Headers show
Series gnu: Add hledger-ui | expand

Commit Message

Tomás Ortín Nov. 24, 2023, 5:22 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-bimap): New variable.

Change-Id: I69d4f1c704ad0ffc27693421d2633ed6bcc4cdf5
---
  gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
  1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e34acca909..d733c6a5f6 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -33,6 +33,7 @@ 
  ;;; Copyright © 2022 jgart <jgart@dismail.de>
  ;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
  ;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
+;;; Copyright © 2023 Tomás Ortín Fernández <tomasortin@mailbox.org>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -2918,6 +2919,26 @@  (define-public ghc-data-ordlist
       "This module provides set and multiset operations on ordered lists.")
      (license license:bsd-3)))

+(define-public ghc-bimap
+  (package
+    (name "ghc-bimap")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "bimap" version))
+       (sha256
+        (base32 "158cdwk9jwklcfgbn62dqq255i40w13ifggsdps87sxc5q7lpd5h"))))
+    (build-system haskell-build-system)
+    (native-inputs (list ghc-quickcheck))
+    (properties '((upstream-name . "bimap")))
+    (home-page "https://github.com/joelwilliamson/bimap")
+    (synopsis "Bidirectional mapping between two key types")
+    (description
+     "Data structure representing a bidirectional mapping between two
+key types.")
+    (license license:bsd-3)))
+
  (define-public ghc-dbus
    (package
      (name "ghc-dbus")