diff mbox series

[bug#52422,v2,1/2] gnu: Add bibutils.

Message ID 4e416f3b4398e16d0e1d570689d50649d35cbc41.camel@gmail.com
State Accepted
Headers show
Series [bug#52422,v2,1/2] gnu: Add bibutils. | expand

Commit Message

Liliana Marie Prikler Dec. 11, 2021, 7:43 a.m. UTC
* gnu/packages/textutils.scm (bibutils): New variable.
---
Am Mittwoch, dem 22.12.2021 um 22:42 +0100 schrieb Ludovic Courtès:
> Bonus points if you change that to:
> 
>   (list #:configure-flags
>         #~(list … #$output …)
>         …)
Watch my street cred go up as I mix quasiquote and gexp 😎
On a related note, is it already known that you can't use
(arguments #~(list ...))?

> GPLv2-only?
Yes.  They don't copypasta the full license blurb, but all file headers
say that the source code is distributed under "GPL version 2".

 gnu/packages/textutils.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Ludovic Courtès Dec. 24, 2021, 2:51 p.m. UTC | #1
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

> * gnu/packages/textutils.scm (bibutils): New variable.
> ---
> Am Mittwoch, dem 22.12.2021 um 22:42 +0100 schrieb Ludovic Courtès:
>> Bonus points if you change that to:
>> 
>>   (list #:configure-flags
>>         #~(list … #$output …)
>>         …)
> Watch my street cred go up as I mix quasiquote and gexp 😎

I try to avoid that because I’m think it can be quite confusing and
intimidating, especially when you end up with sequences like ,#~.
That’s a discussion we should have, but I’m in favor of the above style.

> On a related note, is it already known that you can't use
> (arguments #~(list ...))?

Yes, that’s because ‘arguments’ is literally a list of arguments passed
to the build system with ‘apply’.

>> GPLv2-only?
> Yes.  They don't copypasta the full license blurb, but all file headers
> say that the source code is distributed under "GPL version 2".

V2-only then.

Thanks!

Ludo’.
Liliana Marie Prikler Dec. 24, 2021, 6:14 p.m. UTC | #2
Am Freitag, dem 24.12.2021 um 15:51 +0100 schrieb Ludovic Courtès:
> Hi,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
> 
> > * gnu/packages/textutils.scm (bibutils): New variable.
> > ---
> > Am Mittwoch, dem 22.12.2021 um 22:42 +0100 schrieb Ludovic Courtès:
> > > Bonus points if you change that to:
> > > 
> > >   (list #:configure-flags
> > >         #~(list … #$output …)
> > >         …)
> > Watch my street cred go up as I mix quasiquote and gexp 😎
> 
> I try to avoid that because I’m think it can be quite confusing and
> intimidating, especially when you end up with sequences like ,#~.
> That’s a discussion we should have, but I’m in favor of the above
> style.
Fair enough, I've pushed it with the style you suggested.
>
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 49fcdad47b..a7bff73383 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -44,6 +44,7 @@  (define-module (gnu packages textutils)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix build-system ant)
   #:use-module (guix build-system gnu)
@@ -1137,6 +1138,40 @@  (define-public odt2txt
 OpenDocument presentations (*.odp).")
     (license license:gpl2)))
 
+(define-public bibutils
+  (package
+    (name "bibutils")
+    (version "7.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/bibutils/"
+                                  "bibutils_" version "_src.tgz"))
+
+              (sha256
+               (base32
+                "1hxmwjjzw48w6hdh2x7ybkrhi1xngd55i67hrrd3wswa3vpql0kf"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       ,#~(list "--install-dir" (string-append #$output "/bin")
+                "--install-lib" (string-append #$output "/lib")
+                "--dynamic")
+       #:make-flags
+       ,#~(list (string-append "CC=" #+(cc-for-target))
+                (string-append "LDFLAGSIN=-Wl,-rpath=" #$output "/lib"))
+       #:test-target "test"
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key configure-flags #:allow-other-keys)
+             ;; configure script is ill-formed, invoke it manually
+             (apply invoke "sh" "./configure" configure-flags))))))
+    (home-page "https://bibutils.sourceforge.io/")
+    (synopsis "Convert between various bibliography formats")
+    (description "This package provides converters for various bibliography
+formats (e.g. Bibtex, RIS, ...) using a common XML intermediate.")
+    (license license:gpl2)))
+
 (define-public opencc
   (package
     (name "opencc")