diff mbox series

[bug#65624] gnu: liburcu: Update to 0.14.0.

Message ID 4e237aa21ee92ded2a19ba07814771d96ed07937.1693408885.git.olivier.dion@polymtl.ca
State New
Headers show
Series [bug#65624] gnu: liburcu: Update to 0.14.0. | expand

Commit Message

Olivier Dion Aug. 30, 2023, 3:22 p.m. UTC
From: Olivier Dion <odion@efficios.com>

* gnu/packages/datastructures.scm (liburcu): Update to 0.14.0.
---
 gnu/packages/datastructures.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: ebaff644a6ae87ca289c827d902b46e7877e66ec

Comments

Maxim Cournoyer Sept. 6, 2023, 4:56 a.m. UTC | #1
Hi,

odion@efficios.com writes:

> From: Olivier Dion <odion@efficios.com>
>
> * gnu/packages/datastructures.scm (liburcu): Update to 0.14.0.

According to QA new errors were introduced with this upgrade:
https://qa.guix.gnu.org/issue/65624.  It looks like it broke at least
multipath-tools.
Olivier Dion Sept. 6, 2023, 2:32 p.m. UTC | #2
On Wed, 06 Sep 2023, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
> Hi,
>
> odion@efficios.com writes:
>
>> From: Olivier Dion <odion@efficios.com>
>>
>> * gnu/packages/datastructures.scm (liburcu): Update to 0.14.0.
>
> According to QA new errors were introduced with this upgrade:
> https://qa.guix.gnu.org/issue/65624.  It looks like it broke at least
> multipath-tools.

There are missing include statements in compilation units of multipath-
tools for <assert.h>.  It probably worked before because Userspace RCU
was including it in its public header file and not anymore.  Therefore,
it is a bug of mutlipath-tools which was fixed in version 0.9.6.

So I see two solutions to this.  Either I back-port the patch to version
0.9.3 or we update multipath-tools to 0.9.6.

Thought?
Maxim Cournoyer Sept. 6, 2023, 5:13 p.m. UTC | #3
Hi,

Olivier Dion <odion@efficios.com> writes:

[...]

> There are missing include statements in compilation units of multipath-
> tools for <assert.h>.  It probably worked before because Userspace RCU
> was including it in its public header file and not anymore.  Therefore,
> it is a bug of mutlipath-tools which was fixed in version 0.9.6.
>
> So I see two solutions to this.  Either I back-port the patch to version
> 0.9.3 or we update multipath-tools to 0.9.6.

I'd favor updating multipath-tools; it only 2 dependents, and it's a
patch-level update, so my expectation is that it shouldn't break
anything.
diff mbox series

Patch

diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index bd4f099d94..0689ef4259 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -213,14 +213,14 @@  (define-public libcuckoo
 (define-public liburcu
   (package
     (name "liburcu")
-    (version "0.13.1")
+    (version "0.14.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.lttng.org/files/urcu/"
                                   "userspace-rcu-" version ".tar.bz2"))
               (sha256
                (base32
-                "10rh6v9j13622cjlzx31cfpghjy0kqkvn6pb42whwwcg5cyz64rj"))))
+                "0kwx4fi3gn4p4sdxqkz2zh4z0fv06q449bnz43zjqfad3lkbyhya"))))
     (build-system gnu-build-system)
     (native-inputs
      (list perl))                 ; for tests