diff mbox series

[bug#72741,27/32] gnu: Add python-glue-astronomy.

Message ID 4e21c0b74313d4b840893219793f9b3f87ccf4d6.1724198118.git.sharlatanus@gmail.com
State New
Headers show
Series Astronomy update 2024/08. | expand

Commit Message

Sharlatan Hellseher Aug. 21, 2024, 12:03 a.m. UTC
* gnu/packages/astronomy.scm (python-glue-astronomy): New variable.

Change-Id: Ia11da145d30b221497b71b8ffa49b9522ca547a7
---
 gnu/packages/astronomy.scm | 41 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 6f7fecd8e4..fe74008f7e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1149,6 +1149,47 @@  (define-public ginga-qt5
        (prepend python-pyqt)))
     (synopsis "Qt5 image viewer build based on python-ginga library")))
 
+(define-public python-glue-astronomy
+  (package
+    (name "python-glue-astronomy")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "glue-astronomy" version))
+       (sha256
+        (base32 "1bra11i55g687ykzll5clp7mf3l9kc0x11wqc3gwfi98qx8fgpqz"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      #~(list "--pyargs" "glue_astronomy"
+              ;; XXX: Findout why these tests fail to load:
+              ;; E ModuleNotFoundError: No module named 'glue.qglue'
+              ;; E ImportError: cannot import name 'make_2dspec_image' from
+              ;; 'specreduce.utils.synth_data'
+              "--ignore=glue_astronomy/io/spectral_cube/tests/test_spectral_cube.py"
+              "--ignore=glue_astronomy/io/spectral_cube/tests/test_spectral_cube.py"
+              "--ignore=glue_astronomy/translators/tests/test_trace.py"
+              "--ignore=glue_astronomy/translators/tests/test_trace.py")))
+    (propagated-inputs
+     (list python-astropy
+           python-glue-core
+           python-regions
+           python-specreduce
+           python-spectral-cube
+           python-specutils))
+    (native-inputs
+     (list python-mock
+           python-pytest-astropy
+           python-setuptools-scm))
+    (home-page "https://github.com/glue-viz/glue-astronomy")
+    (synopsis "Astronomy-specific plugins for glue")
+    (description
+     "The glue-astronomy plugin for glue provides a collection of
+astronomy-specific functionality")
+    (license license:bsd-3)))
+
 (define-public python-glue-core
   (package
     (name "python-glue-core")