diff mbox series

[bug#69430,2/2] gnu: sway: Update package style.

Message ID 4e0fe40cb9f4e6974520c36026a233fa300501e3.1709049313.git.hako@ultrarare.space
State New
Headers show
Series [bug#69430,1/2] gnu: sway: Update to 1.9. | expand

Commit Message

Hilton Chain Feb. 27, 2024, 4:08 p.m. UTC
* gnu/packages/wm.scm (sway)[arguments]: Use gexps.
<#:phases>: Adjust to use ‘search-input-file’.
Remove trailing #t.

Change-Id: I5bd91faf2c79566486437b37cf72964d2c6a85fc
---
 gnu/packages/wm.scm | 27 ++++++++++++++-------------
 1 file changed, 14 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 90d61d1d86..e5bc434166 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1769,19 +1769,20 @@  (define-public sway
         (base32 "1n36vgpi4bg2gkiq4fam4khly1z9bjinmjclzq5vfx0z8h7a5bzz"))))
     (build-system meson-build-system)
     (arguments
-     `(;; elogind is propagated by wlroots -> libseat
-       ;; and would otherwise shadow basu.
-       #:configure-flags '("-Dsd-bus-provider=basu")
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'hardcode-paths
-           (lambda* (#:key inputs #:allow-other-keys)
-             ;; Hardcode path to swaybg.
-             (substitute* "sway/config.c"
-               (("strdup..swaybg..")
-                (string-append "strdup(\"" (assoc-ref inputs "swaybg")
-                               "/bin/swaybg\")")))
-             #t)))))
+     (list
+      ;; elogind is propagated by wlroots -> libseat
+      ;; and would otherwise shadow basu.
+      #:configure-flags
+      #~'("-Dsd-bus-provider=basu")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'configure 'hardcode-paths
+            (lambda* (#:key inputs #:allow-other-keys)
+              ;; Hardcode path to swaybg.
+              (substitute* "sway/config.c"
+                (("strdup..swaybg..")
+                 (format #f "strdup(\"~a\")"
+                         (search-input-file inputs "bin/swaybg")))))))))
     (inputs (list basu
                   cairo
                   gdk-pixbuf