diff mbox series

[bug#40471] gnu: Add lsp-plugins.

Message ID 4df3ebd1eb7b6bfbdac5f4840e13756427ca0a8f.camel@zrythm.org
State Accepted
Headers show
Series [bug#40471] gnu: Add lsp-plugins. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou May 27, 2020, 12:06 a.m. UTC
Fixed! The failure was due to the lv2 upgrade. The upstream has fixed
this in the new release.

See new patch attached.

Thanks,
Alex

On Wed, 2020-05-06 at 22:55 +0300, Efraim Flashner wrote:
> This actually failed to build for me, even when I bumped the version
> up
> to 1.1.19. Can you take a look at it?
> 
> Thanks
> 
>

Comments

Efraim Flashner May 27, 2020, 9:25 a.m. UTC | #1
Patched pushed with a few changes:

On Wed, May 27, 2020 at 01:06:38AM +0100, Alexandros Theodotou wrote:
> Fixed! The failure was due to the lv2 upgrade. The upstream has fixed
> this in the new release.
> 
> See new patch attached.
> 
> Thanks,
> Alex
> 
> On Wed, 2020-05-06 at 22:55 +0300, Efraim Flashner wrote:
> > This actually failed to build for me, even when I bumped the version
> > up
> > to 1.1.19. Can you take a look at it?
> > 
> > Thanks
> > 
> > 

> From b3aa2ea22bc2be15a7ab11c792ea85a1ec3900d6 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Wed, 27 May 2020 01:04:42 +0100
> Subject: [PATCH] gnu: Add lsp-plugins.
> 
> * gnu/packages/music.scm (lsp-plugins): new variable.
> ---
>  gnu/packages/music.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 43 insertions(+)
> 
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 2c6be8eba8..f01978d118 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -4863,6 +4863,49 @@ effects.  It contains a bitcrusher, delay, distortion, equalizer, compressor,
>  and reverb.")
>      (license license:gpl2+)))
>  
> +(define-public lsp-plugins
> +  (package
> +    (name "lsp-plugins")
> +    (version "1.1.21")
> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri (git-reference
> +               (url "https://github.com/sadko4u/lsp-plugins.git")
> +               (commit (string-append "lsp-plugins-" version))))
> +        (file-name (git-file-name name version))
> +        (sha256
> +          (base32
> +            "1zw0iip6ki9k65kh8dp53x7l4va4mi5rj793n2yn4p9y84qzwrz9"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:make-flags

I changed the CC=gcc line so that it can cross compile

> +       (list "CC=gcc" "BUILD_MODULES=\"lv2 ladspa jack\"" "VST_UI=0"
> +             (string-append "PREFIX=" (assoc-ref %outputs "out"))
> +             (string-append "ETC_PATH=" (assoc-ref %outputs "out") "/etc"))
> +       #:phases
> +       (modify-phases %standard-phases
> +         (delete 'configure) ; no configure

I changed this to a #:test-flag

> +         (replace 'check
> +           (lambda _
> +             (invoke "make" "test"))))))

And I re-indented so that the ` was under the 'i' in inputs.
Same with native-inputs.

> +    (inputs
> +      `(("cairo", cairo)
> +        ("hicolor-icon-theme", hicolor-icon-theme)
> +        ("jack", jack-1)
> +        ("ladspa", ladspa)
> +        ("libsndfile", libsndfile)
> +        ("lv2", lv2)
> +        ("mesa", mesa)))
> +    (native-inputs
> +      `(("pkg-config", pkg-config)))
> +    (synopsis "Audio plugin collection")
> +    (description "LSP (Linux Studio Plugins) is a collection of audio
> +plugins available as LADSPA/LV2 plugins and as standalone JACK
> +applications.")
> +    (home-page "https://lsp-plug.in/")
> +    (license license:lgpl3)))
> +
>  (define-public sherlock-lv2
>    (package
>      (name "sherlock-lv2")
> -- 
> 2.26.2
>
diff mbox series

Patch

From b3aa2ea22bc2be15a7ab11c792ea85a1ec3900d6 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 27 May 2020 01:04:42 +0100
Subject: [PATCH] gnu: Add lsp-plugins.

* gnu/packages/music.scm (lsp-plugins): new variable.
---
 gnu/packages/music.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2c6be8eba8..f01978d118 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4863,6 +4863,49 @@  effects.  It contains a bitcrusher, delay, distortion, equalizer, compressor,
 and reverb.")
     (license license:gpl2+)))
 
+(define-public lsp-plugins
+  (package
+    (name "lsp-plugins")
+    (version "1.1.21")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/sadko4u/lsp-plugins.git")
+               (commit (string-append "lsp-plugins-" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "1zw0iip6ki9k65kh8dp53x7l4va4mi5rj793n2yn4p9y84qzwrz9"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (list "CC=gcc" "BUILD_MODULES=\"lv2 ladspa jack\"" "VST_UI=0"
+             (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             (string-append "ETC_PATH=" (assoc-ref %outputs "out") "/etc"))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure) ; no configure
+         (replace 'check
+           (lambda _
+             (invoke "make" "test"))))))
+    (inputs
+      `(("cairo", cairo)
+        ("hicolor-icon-theme", hicolor-icon-theme)
+        ("jack", jack-1)
+        ("ladspa", ladspa)
+        ("libsndfile", libsndfile)
+        ("lv2", lv2)
+        ("mesa", mesa)))
+    (native-inputs
+      `(("pkg-config", pkg-config)))
+    (synopsis "Audio plugin collection")
+    (description "LSP (Linux Studio Plugins) is a collection of audio
+plugins available as LADSPA/LV2 plugins and as standalone JACK
+applications.")
+    (home-page "https://lsp-plug.in/")
+    (license license:lgpl3)))
+
 (define-public sherlock-lv2
   (package
     (name "sherlock-lv2")
-- 
2.26.2