diff mbox series

[bug#71599,gnome-team,2/2] gnu: tracker-miners: Update to 3.7.3.

Message ID 4db9fdd97efd92280fd206d4a91f002bd2da36ac.1718569527.git.liliana.prikler@gmail.com
State New
Headers show
Series Update Tracker | expand

Commit Message

Liliana Marie Prikler June 16, 2024, 8:24 p.m. UTC
* gnu/packages/gnome.scm (tracker-miners): Update to 3.7.3.
[#:configure-flags]: Add “-Dlandlock=disabled”.
---
 gnu/packages/gnome.scm | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

Comments

Maxim Cournoyer June 17, 2024, 7:58 p.m. UTC | #1
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/gnome.scm (tracker-miners): Update to 3.7.3.
> [#:configure-flags]: Add “-Dlandlock=disabled”.
> ---
>  gnu/packages/gnome.scm | 8 ++++++--
>  1 file changed, 6 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index d7a8f12550..ce20262d2d 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -9766,7 +9766,7 @@ (define-public tracker
>  (define-public tracker-miners
>    (package
>      (name "tracker-miners")
> -    (version "3.6.1")
> +    (version "3.7.3")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "mirror://gnome/sources/tracker-miners/"
> @@ -9774,7 +9774,7 @@ (define-public tracker-miners
>                                    "/tracker-miners-" version ".tar.xz"))
>                (sha256
>                 (base32
> -                "13ljx0birrav728ik3bnlwzgas8q6rbhjbvxp7zzwy6ambafiw7f"))))
> +                "1zm57pih7csgipw3w2b1sgadvfszik70sbz4gr5pn6aw9caqhhz7"))))
>      (build-system meson-build-system)
>      (arguments
>       `(#:glib-or-gtk? #t
> @@ -9784,6 +9784,10 @@ (define-public tracker-miners
>               (string-append "-Dc_link_args=-Wl,-rpath="
>                              (assoc-ref %outputs "out")
>                              "/lib/tracker-miners-3.0")
> +             ;; TODO: Check if this is only a build-time failure,
> +             ;; or add variants to explicitly enable this features, see also
> +             ;; <https://gitlab.gnome.org/GNOME/tracker-miners/-/issues/300>.

Purely cosmetic and inconsequential, but Ludovic once taught me to use
something like:

--8<---------------cut here---------------start------------->8---
;; TODO: Check if this is only a build-time failure, or add variants to
;; explicitly enable this features (see:
;; https://gitlab.gnome.org/GNOME/tracker-miners/-/issues/300).
--8<---------------cut here---------------end--------------->8---

which I find elegant.
Liliana Marie Prikler June 17, 2024, 8:45 p.m. UTC | #2
Am Montag, dem 17.06.2024 um 15:58 -0400 schrieb Maxim Cournoyer:
> Hi Liliana,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/gnome.scm (tracker-miners): Update to 3.7.3.
> > [#:configure-flags]: Add “-Dlandlock=disabled”.
> > ---
> >  gnu/packages/gnome.scm | 8 ++++++--
> >  1 file changed, 6 insertions(+), 2 deletions(-)
> > 
> > diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> > index d7a8f12550..ce20262d2d 100644
> > --- a/gnu/packages/gnome.scm
> > +++ b/gnu/packages/gnome.scm
> > @@ -9766,7 +9766,7 @@ (define-public tracker
> >  (define-public tracker-miners
> >    (package
> >      (name "tracker-miners")
> > -    (version "3.6.1")
> > +    (version "3.7.3")
> >      (source (origin
> >                (method url-fetch)
> >                (uri (string-append "mirror://gnome/sources/tracker-
> > miners/"
> > @@ -9774,7 +9774,7 @@ (define-public tracker-miners
> >                                    "/tracker-miners-" version
> > ".tar.xz"))
> >                (sha256
> >                 (base32
> > -               
> > "13ljx0birrav728ik3bnlwzgas8q6rbhjbvxp7zzwy6ambafiw7f"))))
> > +               
> > "1zm57pih7csgipw3w2b1sgadvfszik70sbz4gr5pn6aw9caqhhz7"))))
> >      (build-system meson-build-system)
> >      (arguments
> >       `(#:glib-or-gtk? #t
> > @@ -9784,6 +9784,10 @@ (define-public tracker-miners
> >               (string-append "-Dc_link_args=-Wl,-rpath="
> >                              (assoc-ref %outputs "out")
> >                              "/lib/tracker-miners-3.0")
> > +             ;; TODO: Check if this is only a build-time failure,
> > +             ;; or add variants to explicitly enable this
> > features, see also
> > +             ;;
> > <https://gitlab.gnome.org/GNOME/tracker-miners/-/issues/300>.
> 
> Purely cosmetic and inconsequential, but Ludovic once taught me to
> use something like:
> 
> --8<---------------cut here---------------start------------->8---
> ;; TODO: Check if this is only a build-time failure, or add variants
> to
> ;; explicitly enable this features (see:
> ;; https://gitlab.gnome.org/GNOME/tracker-miners/-/issues/300).
> --8<---------------cut here---------------end--------------->8---
> 
> which I find elegant.
In other words, I should not use <> for URIs, but instead use brackets
for the whole see expression?
Maxim Cournoyer June 17, 2024, 11:47 p.m. UTC | #3
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Montag, dem 17.06.2024 um 15:58 -0400 schrieb Maxim Cournoyer:
>> Hi Liliana,
>> 
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>> 
>> > * gnu/packages/gnome.scm (tracker-miners): Update to 3.7.3.
>> > [#:configure-flags]: Add “-Dlandlock=disabled”.
>> > ---
>> >  gnu/packages/gnome.scm | 8 ++++++--
>> >  1 file changed, 6 insertions(+), 2 deletions(-)
>> > 
>> > diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
>> > index d7a8f12550..ce20262d2d 100644
>> > --- a/gnu/packages/gnome.scm
>> > +++ b/gnu/packages/gnome.scm
>> > @@ -9766,7 +9766,7 @@ (define-public tracker
>> >  (define-public tracker-miners
>> >    (package
>> >      (name "tracker-miners")
>> > -    (version "3.6.1")
>> > +    (version "3.7.3")
>> >      (source (origin
>> >                (method url-fetch)
>> >                (uri (string-append "mirror://gnome/sources/tracker-
>> > miners/"
>> > @@ -9774,7 +9774,7 @@ (define-public tracker-miners
>> >                                    "/tracker-miners-" version
>> > ".tar.xz"))
>> >                (sha256
>> >                 (base32
>> > -               
>> > "13ljx0birrav728ik3bnlwzgas8q6rbhjbvxp7zzwy6ambafiw7f"))))
>> > +               
>> > "1zm57pih7csgipw3w2b1sgadvfszik70sbz4gr5pn6aw9caqhhz7"))))
>> >      (build-system meson-build-system)
>> >      (arguments
>> >       `(#:glib-or-gtk? #t
>> > @@ -9784,6 +9784,10 @@ (define-public tracker-miners
>> >               (string-append "-Dc_link_args=-Wl,-rpath="
>> >                              (assoc-ref %outputs "out")
>> >                              "/lib/tracker-miners-3.0")
>> > +             ;; TODO: Check if this is only a build-time failure,
>> > +             ;; or add variants to explicitly enable this
>> > features, see also
>> > +             ;;
>> > <https://gitlab.gnome.org/GNOME/tracker-miners/-/issues/300>.
>> 
>> Purely cosmetic and inconsequential, but Ludovic once taught me to
>> use something like:
>> 
>> --8<---------------cut here---------------start------------->8---
>> ;; TODO: Check if this is only a build-time failure, or add variants
>> to
>> ;; explicitly enable this features (see:
>> ;; https://gitlab.gnome.org/GNOME/tracker-miners/-/issues/300).
>> --8<---------------cut here---------------end--------------->8---
>> 
>> which I find elegant.
> In other words, I should not use <> for URIs, but instead use brackets
> for the whole see expression?

The recipe of that scheme is (see: $url) -- the parentheses are
important.

But otherwise, it's just a convention I've seen used often in the code
base (because Ludovic and probably others like me use it as well).

-- 
Thanks,
Maxim
Liliana Marie Prikler June 23, 2024, 1:54 p.m. UTC | #4
Hi Maxim,

Am Montag, dem 17.06.2024 um 19:47 -0400 schrieb Maxim Cournoyer:
> The recipe of that scheme is (see: $url) -- the parentheses are
> important.
> 
> But otherwise, it's just a convention I've seen used often in the
> code base (because Ludovic and probably others like me use it as
> well).
Welp, thanks for the clarification, I've pushed it with the proposed
scheme.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d7a8f12550..ce20262d2d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9766,7 +9766,7 @@  (define-public tracker
 (define-public tracker-miners
   (package
     (name "tracker-miners")
-    (version "3.6.1")
+    (version "3.7.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/tracker-miners/"
@@ -9774,7 +9774,7 @@  (define-public tracker-miners
                                   "/tracker-miners-" version ".tar.xz"))
               (sha256
                (base32
-                "13ljx0birrav728ik3bnlwzgas8q6rbhjbvxp7zzwy6ambafiw7f"))))
+                "1zm57pih7csgipw3w2b1sgadvfszik70sbz4gr5pn6aw9caqhhz7"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t
@@ -9784,6 +9784,10 @@  (define-public tracker-miners
              (string-append "-Dc_link_args=-Wl,-rpath="
                             (assoc-ref %outputs "out")
                             "/lib/tracker-miners-3.0")
+             ;; TODO: Check if this is only a build-time failure,
+             ;; or add variants to explicitly enable this features, see also
+             ;; <https://gitlab.gnome.org/GNOME/tracker-miners/-/issues/300>.
+             "-Dlandlock=disabled"
              ;; TODO: Enable functional tests. Currently, the following error
              ;; appears:
              ;; Exception: The functional tests require DConf to be the default