[bug#77322] gnu: profanity: Update to 0.15.0.

Message ID 4d99c627298f220c26097ade4e0f85f05bb3cff9.1743597132.git.andreas@enge.fr
State New
Headers
Series [bug#77322] gnu: profanity: Update to 0.15.0. |

Commit Message

Andreas Enge April 2, 2025, 12:32 p.m. UTC
  From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/messaging.scm (profanity): Update to 0.15.0.
[arguments]<#:phases>: Add patch-python-plugins phase.

Change-Id: I654a9648d973653fd44b19fcacd822bbb0570fd9
Co-authored-by: Andreas Enge <andreas@enge.fr>
---
Hello,

here is an alternative version with more consistent use of gexps instead
of a mixture of traditional quoting and unquoting and gexps.

It builds on x86_64, with a bit of luck it will be picked up by QA soon.

Andreas


 gnu/packages/messaging.scm | 34 +++++++++++++++++++++-------------
 1 file changed, 21 insertions(+), 13 deletions(-)


base-commit: 407963a8489a319c4a88c2fdfdc9c61d33a1eb0d
  

Comments

Andreas Enge April 2, 2025, 8:56 p.m. UTC | #1
QA has picked it up, pushed!

Andreas
  

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 6e6223d1b9..26db072b4a 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2246,7 +2246,7 @@  (define-public libstrophe
 (define-public profanity
   (package
     (name "profanity")
-    (version "0.14.0")
+    (version "0.15.0")
     (source
      (origin
        (method url-fetch)
@@ -2255,20 +2255,28 @@  (define-public profanity
                        version ".tar.gz"))
        (sha256
         (base32
-         "0zygsxxwdxmpppr7vyzi2r7d854yjl6918w0lrs7k41iib9zy8zx"))))
+         "1yy7x9ycqg6c65k66z47p8mvj48qc0pa4as1lk1agj8ffn7mg7sa"))))
     (build-system glib-or-gtk-build-system)
     (arguments
-     `(#:configure-flags
-       (list
-        "--disable-static"
-        "--enable-notifications"
-        "--enable-python-plugins"
-        "--enable-c-plugins"
-        "--enable-plugins"
-        "--enable-otr"
-        "--enable-pgp"
-        "--enable-omemo"
-        "--enable-icons-and-clipboard")))
+     (list
+       #:configure-flags
+         #~(list
+           "--disable-static"
+           "--enable-notifications"
+           "--enable-python-plugins"
+           "--enable-c-plugins"
+           "--enable-plugins"
+           "--enable-otr"
+           "--enable-pgp"
+           "--enable-omemo"
+           "--enable-icons-and-clipboard")
+       #:phases
+       #~(modify-phases %standard-phases
+           (add-after 'unpack 'patch-python-plugins
+             (lambda _
+               ;; Py_XDECREF is a macro in Python 3.10
+               (substitute* "src/plugins/python_plugins.c"
+                 (("Py_XDECREF") "_Py_XDECREF")))))))
     (native-inputs
      (list autoconf
            autoconf-archive