diff mbox series

[bug#62262,v3,2/2] gnu: Add xfishtank.

Message ID 4cf6c8c0f00983e872f89836c3764dd35efae462.1708189137.git.steve@futurile.net
State New
Headers show
Series Add xfishtank and xpenguins | expand

Commit Message

Steve George Feb. 17, 2024, 5:12 p.m. UTC
From: Sarthak Shah <shahsarthakw@gmail.com>

* gnu/packages/toys.scm (xfishtank): New variable.

Reviewed-by: Greg Hogan <code@greghogan.com>
Reviewed-by: Steve George <steve@futurile.net>

Change-Id: I490fba2d9ded274266d6376adf67c39bf5c9744a
---
 gnu/packages/toys.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 6fdc931ae66..072b6200dad 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -433,6 +433,41 @@  (define-public xpenguins
 run paths.")
     (license license:gpl2+)))
 
+(define-public xfishtank
+  (package
+    (name "xfishtank")
+    (version "3.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+              "https://www.ratrabbit.nl/downloads/xfishtank/xfishtank-"
+              version "~pre1.tar.gz"))
+       ;; version has ~pre1 in it. Guix store does not allow tilde
+       ;; in file names. Save it in the Store using a hyphen
+       (file-name (string-append name "-" version "-pre1.tar.gz"))
+       (sha256
+        (base32 "16i9diawkmar6dhx5xn0mflr2h585gamab6137hvxzgaczx55lwp"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-install-path
+           (lambda _
+             ;; Install program to bin instead of games.
+             (substitute* "src/Makefile.in"
+               (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+                (string-append prefix "bin"))))))))
+    (inputs
+     (list gtk+ libx11 libxpm libxt libxml2))
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://www.ratrabbit.nl/ratrabbit/software/xfishtank/index.html")
+    (synopsis "Let fish swim over your desktop!")
+    (description "@code{Xfishtank} is a well-known vintage application for Unix
+systems, that uses the X11 protocol.  It shows fish swimming over the desktop.")
+    (license (list license:expat license:gpl3+))))
+
 (define-public nyancat
   (package
     (name "nyancat")