diff mbox series

[bug#57773] gnu: add emacs-transpose-mark

Message ID 4cf1bdb4958b51e84246995340c3f4322d3629da.1663273749.git.trev@trevdev.ca
State Accepted
Headers show
Series [bug#57773] gnu: add emacs-transpose-mark | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Trevor Richards Sept. 13, 2022, 3:21 p.m. UTC
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou Sept. 18, 2022, 9:26 a.m. UTC | #1
Hello,

Trevor Richards <trev@trevdev.ca> writes:

> +(define-public emacs-transpose-mark
> +  (let ((commit "667327602004794de97214cf336ac61650ef75b7")
> +        (revision "0"))

Thank you. I normalized your commit message and applied your patch with
the changes below.

> +    (package
> +      (name "emacs-transpose-mark")
> +      (version (git-version "0.0.1" revision commit))

Base version is actually "0": I couldn't find any tag nor a Version keyord. 

> +         (uri (git-reference
> +               (url "https://github.com/kwrooijen/transpose-mark.git")

I removed the ".git" suffix.

> +      (home-page "https://github.com/kwrooijen/transpose-mark.git")

Ditto.

> +      (synopsis "A small library for transposing lines and regions.")

Synopsis are not expected to start with an article, nor end with a full
stop.

> +      (description "Transpose mark provides some commands that makes
> +transposing lines and regions easier. You can mark a line and transpose it
> +with a line at point, or \"mark\" a region and transpose it with another
> +region a point. The plugin provides visual feedback for marked
> regions.")

I added two spaces between sentences.

> +      (license license:gpl3))))

License is "gpl3+": it contains "or (at your option) any later version"

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 19be038746..7b85a0f5ec 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15771,6 +15771,30 @@  (define-public emacs-transpose-frame
 selected frame.")
     (license license:bsd-2)))
 
+(define-public emacs-transpose-mark
+  (let ((commit "667327602004794de97214cf336ac61650ef75b7")
+        (revision "0"))
+    (package
+      (name "emacs-transpose-mark")
+      (version (git-version "0.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/kwrooijen/transpose-mark.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "03wc50vn1kmrgnzzhs06pwpap2p2rx84wwzxw0hawsg1f1l35m2x"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/kwrooijen/transpose-mark.git")
+      (synopsis "A small library for transposing lines and regions.")
+      (description "Transpose mark provides some commands that makes
+transposing lines and regions easier. You can mark a line and transpose it
+with a line at point, or \"mark\" a region and transpose it with another
+region a point. The plugin provides visual feedback for marked regions.")
+      (license license:gpl3))))
+
 (define-public emacs-key-chord
   (package
     (name "emacs-key-chord")