diff mbox series

[bug#64992] gnu: Add python-baltica.

Message ID 4cf18f120f7829851d9bc97ce7210b04fde22f72.1690897596.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#64992] gnu: Add python-baltica. | expand

Commit Message

nafkhamdc Aug. 1, 2023, 1:46 p.m. UTC
* gnu/packages/bioinformatics.scm (python-baltica): New variable.
---
 gnu/packages/bioinformatics.scm | 43 +++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)


base-commit: 34b56974dfe720e5e30f04409ac216747d7e3f5c

Comments

Ricardo Wurmus Aug. 2, 2023, 6:48 a.m. UTC | #1
Pushed with commit 5a293d0830aa9369e388d37fe767d5bf98af01b7.  Thanks for
the patch!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6080c899af..6d745262b3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5056,6 +5056,49 @@  (define-public edirect-go-programs
            go-golang-org-x-image
            go-golang-org-x-text))))
 
+(define-public python-baltica
+  (package
+    (name "python-baltica")
+    (version "1.1.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dieterich-lab/Baltica")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "001ac03v9pbqqzf9pv7v8gf0296ksa4f0v3wdmpa6m9701skqi4r"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases '(modify-phases %standard-phases
+                       (replace 'check
+                         (lambda _
+                           ;; The tests need to be run from elsewhere...
+                           (mkdir-p "/tmp/test")
+                           (copy-recursively ".tests" "/tmp/test")
+                           (with-directory-excursion "/tmp/test"
+                             (invoke "pytest" "-v" "--doctest-modules")))))))
+    (propagated-inputs (list python-anndata
+                             python-click
+                             python-flask
+                             python-flask-wtf
+                             gunicorn
+                             python-h5py
+                             python-pysam
+                             python-numpy
+                             python-psutil
+                             python-pyyaml
+                             python-scipy
+                             snakemake-7))
+    (native-inputs (list python-pytest python-pyfakefs python-cython))
+    (home-page "https://github.com/dieterich-lab/Baltica")
+    (synopsis "Integrated splice junction usage analysis")
+    (description
+     "This framework facilitates the execution of differential junction usage methods.
+Additionally, it enables the integration of results from multiple DJU methods.")
+    (license license:expat)))
+
 (define-public python-bamnostic
   (package
     (name "python-bamnostic")