diff mbox series

[bug#64348,v2] gnu: Add durden.

Message ID 4c9840333f6e8f3f44448d55b095771f458129ee.1702141296.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#64348,v2] gnu: Add durden. | expand

Commit Message

Ahmad Draidi Dec. 9, 2023, 5:01 p.m. UTC
* gnu/packages/arcan.scm (durden): New variable.

Change-Id: I489409e161d20d1170923664aee01c4229f7a6f5
---
v2 changes: Rebase to fix conflicts

 gnu/packages/arcan.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: 61f2d84e75c340c2ba528d392f522c51b8843f34
diff mbox series

Patch

diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
index 4ca76edbec..3f8fc7c219 100644
--- a/gnu/packages/arcan.scm
+++ b/gnu/packages/arcan.scm
@@ -20,6 +20,7 @@ 
 
 (define-module (gnu packages arcan)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system gnu)
   #:use-module (guix gexp)
@@ -183,6 +184,41 @@  (define-public arcan-sdl
               "-DSTATIC_FREETYPE=off" "-DSHMIF_TUI_ACCEL=on")))))
     (synopsis "Combined display server, multimedia framework and game engine (SDL)")))
 
+(define-public durden
+  (package
+    (name "durden")
+    (version "0.6.1")
+    (source
+     (origin
+       (method git-fetch)
+       (file-name (git-file-name name version))
+       (uri (git-reference
+             (url "https://github.com/letoram/durden")
+             (commit version)))
+       (sha256
+        (base32 "03ry8ypsvpjydb9s4c28y3iffz9375pfgwq9q9y68hmj4d89bjvz"))))
+    (build-system copy-build-system)
+    (arguments
+     (list
+      #:install-plan #~'(("durden/" "share/arcan/appl/durden/")
+                         ("distr/durden" "bin/durden"))
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'patch-paths
+                     (lambda* (#:key outputs #:allow-other-keys)
+                       (substitute* "distr/durden"
+                         (("/usr/share/\\$applname")
+                          (string-append (assoc-ref outputs "out")
+                                         "/share/arcan/appl"))))))))
+    (home-page "https://durden.arcan-fe.com/")
+    (synopsis "Desktop Environment for Arcan")
+    (description
+     "Durden is a desktop environment for the Arcan Display Server.
+It serves both as a reference showcase on how to take advantage of some of the
+features in Arcan, and as an entry to the advanced-user side of the desktop
+environment spectrum.")
+    (license (list license:bsd-3 license:expat license:cc-by3.0
+                   license:cc-by4.0 license:asl2.0))))
+
 (define-public xarcan
   (package
     (name "xarcan")