diff mbox series

[bug#74345,2/9] gnu: python-botocore: Update to 1.35.59.

Message ID 4c0b3d3c8f8b3f118247b7a6c7960ca23f8c94b3.1731518182.git.rekado@elephly.net
State New
Headers show
Series [bug#74345,1/9] gnu: python-s3transfer: Update to 0.10.3. | expand

Commit Message

Ricardo Wurmus Nov. 13, 2024, 5:16 p.m. UTC
* gnu/packages/python-xyz.scm (python-botocore): Update to 1.35.59.
[build-system]: Use pyproject-build-system.
[arguments]: Enable most tests.
[native-inputs]: Add python-jsonschema and python-pytest.

Change-Id: Iee873e6a84d582271fcbcd39e78521583574fb40
---
 gnu/packages/python-xyz.scm | 14 +++++++++-----
 1 file changed, 9 insertions(+), 5 deletions(-)

Comments

Sharlatan Hellseher Nov. 13, 2024, 6:48 p.m. UTC | #1
https://git.savannah.gnu.org/cgit/guix.git/log/?h=python-team&ofs=50

Majority tests were passed successfully

https://git.savannah.gnu.org/cgit/guix.git/commit/?h=python-team&id=f4d1cbd70149df83f1d8045f27bea924b58d21ff

My plan on python team branch to fix all faults introduced by
 pyproject build system update, cherry pick "Adjust inputs"
 commits and, squash them into one, which may merge to master directly.

Thanks,

Oleg
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5083473c080..3be34786be5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19364,20 +19364,24 @@  (define-public python-botocore
   ;; are compatible.
   (package
     (name "python-botocore")
-    (version "1.24.35")
+    (version "1.35.59")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "botocore" version))
        (sha256
         (base32
-         "0rv8mvhq5s373zdjs2yb45hzvqcqdh2lp2rbb21jjc8ciwnl5d9n"))))
-    (build-system python-build-system)
+         "161wp1ribgkc23w6wcfs6zzig2j84ava7ylxhs3jrh6zzrayc36y"))))
+    (build-system pyproject-build-system)
     (arguments
-     ;; FIXME: Many tests are failing.
-     '(#:tests? #f))
+     (list
+      #:test-flags
+      ;; FIXME: Many tests are failing.
+      '(list "--ignore-glob=tests/functional/leak/*"
+             "--ignore-glob=tests/integration/*")))
     (propagated-inputs
      (list python-dateutil python-jmespath python-urllib3))
+    (native-inputs (list python-jsonschema python-pytest))
     (home-page "https://github.com/boto/botocore")
     (synopsis "Low-level interface to AWS")
     (description "Botocore is a Python library that provides a low-level