@@ -19364,20 +19364,24 @@ (define-public python-botocore
;; are compatible.
(package
(name "python-botocore")
- (version "1.24.35")
+ (version "1.35.59")
(source
(origin
(method url-fetch)
(uri (pypi-uri "botocore" version))
(sha256
(base32
- "0rv8mvhq5s373zdjs2yb45hzvqcqdh2lp2rbb21jjc8ciwnl5d9n"))))
- (build-system python-build-system)
+ "161wp1ribgkc23w6wcfs6zzig2j84ava7ylxhs3jrh6zzrayc36y"))))
+ (build-system pyproject-build-system)
(arguments
- ;; FIXME: Many tests are failing.
- '(#:tests? #f))
+ (list
+ #:test-flags
+ ;; FIXME: Many tests are failing.
+ '(list "--ignore-glob=tests/functional/leak/*"
+ "--ignore-glob=tests/integration/*")))
(propagated-inputs
(list python-dateutil python-jmespath python-urllib3))
+ (native-inputs (list python-jsonschema python-pytest))
(home-page "https://github.com/boto/botocore")
(synopsis "Low-level interface to AWS")
(description "Botocore is a Python library that provides a low-level